This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: gdb - few problems

Bogdan Slusarczyk wrote:
I've tried to use gdb6.7.50.20071127 (mingw). I noticed few problems (in comparison with gdb6.7.1).

1) after attaching to process 'info shared' returns: "No shared libraries loaded at this time" (gdb6.7.1 returns few libraries)

I can reproduce this when attaching without specifying the executable 'gdb --pid $pid', and can't if I do specify it. I take it that's what you mean.

2) debugged process has loaded shared library using LoadLibrary, and I cannot set breakpoint in this library. I get: "No symbol table is loaded. Use the "file" command" (using gdb6.7.1 I can set breakpoint without problem).

I haven't tried to reproduce this, but from the description, it either, looks like the same problem -- GDB should have at least minimal symbols from the loaded dlls (extracted from the dll's export table) ; if it didn't find the dlls, and you didn't pass a symbol file on the command line, there will be no symbol table loaded or looks like related to PR2368 and/or PR2369.

Why I have to use 'file' command (and 'symbol-file' too)? It works with mentioned commands but I'm wondering it's intended behaviour or bug?


Could you open a bug report for 1) ?

(Also, when reporting win32 bugs, it would be nice to also
test it on a cygwin build -- nice, but not required.)

Pedro Alves

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]