Bug 5663 - java.lang.UnsatisfiedLinkError: libEggTrayIcon
Summary: java.lang.UnsatisfiedLinkError: libEggTrayIcon
Status: NEW
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Unassigned
Depends on:
Blocks: 1632
  Show dependency treegraph
Reported: 2008-01-24 18:32 UTC by Sami Wagiaalla
Modified: 2008-01-30 15:20 UTC (History)
0 users

See Also:
Last reconfirmed:


Note You need to log in before you can comment on or make changes to this bug.
Description Sami Wagiaalla 2008-01-24 18:32:17 UTC
when run from the root directory FryskGui crashes:

frysk> ./frysk-gui/frysk/gui/FryskGui Exception in thread "main"
java.lang.UnsatisfiedLinkError: libEggTrayIcon: libEggTrayIcon.so: cannot open
shared object file: No such file or directory
   at java.lang.Runtime._load(libgcj.so.8rh)
   at java.lang.Runtime.loadLibrary(libgcj.so.8r

the relative path here:


is likely to be the cause
Comment 1 Andrew Cagney 2008-01-24 18:45:53 UTC
I'm not sure that this ever worked.

Try LD_LIBRARY_PATH=<egg-tray-so-directory> .../FryskGui

Two things determine of that .so is found:  The LD_LIBRARY_PATH / -rpath command
line option; and the -Djava.library.path=...

Comment 2 Mark Wielaard 2008-01-30 15:20:08 UTC
(In reply to comment #1)
> I'm not sure that this ever worked.

It worked previously. Although the workaround is easy.