This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: RFC: requiring GCC >= 4.7 to build glibc

Would anyone else like to comment on (a) the general principle of doing 
time-based upgrades of the minimum GCC and binutils versions for building 
glibc (so typically upgrade every other glibc release cycle, since GCC and 
binutils have major releases about once a year) or (b) this particular 
proposed increase?

For Linux kernel support I think the conclusion from the thread starting 
at <> was to 
default to not supporting kernel versions not maintained upstream, unless 
discussion indicates there are important distribution versions with older 
kernels we wish to continue to support (when 2.6.32 ceases to be 
supported, <> says 
"Mid-2015", I'll start the discussion of moving to 3.2 as minimum).  The 
discussion there noted cases where people control the userland but not the 
kernel; that isn't an issue with GCC and binutils (people can always build 
newer versions themselves if they wish to build new glibc on an old 
distribution), so if anything I think we can be less conservative about 
version requirements for GCC and binutils than for the Linux kernel.

For reference:

GCC 4.6 (current GCC requirement) was first released March 2011, last 4.6 
branch release April 2013.  Binutils 2.22 (current binutils requirement) 
was released November 2011.

Joseph S. Myers

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]