This is the mail archive of the
mailing list for the glibc project.
RFC: requiring GCC >= 4.7 to build glibc
- From: Joseph Myers <joseph at codesourcery dot com>
- To: <libc-alpha at sourceware dot org>
- Date: Thu, 20 Aug 2015 13:51:21 +0000
- Subject: RFC: requiring GCC >= 4.7 to build glibc
- Authentication-results: sourceware.org; auth=none
For glibc 2.21 we increased the minimum GCC version for building glibc to
4.6. There's one major GCC release a year, so the correspondingly old
version for glibc 2.23 would be GCC 4.7. What do people think about
increasing the minimum version requirement?
* Being able to assume __atomic_* are supported by the compiler if
* When using pragmas to disable -Wmaybe-uninitialized warnings, no need to
have conditionals to disable -Wuninitialized instead for 4.6
(-Wmaybe-uninitialized was added in 4.7).
* More C11 support, so we no longer need to XFAIL some conform/ tests and
could use the new features in glibc if desired.
Joseph S. Myers