This is the mail archive of the gdb@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: gdb 8.x - g++ 7.x compatibility


On 2018-02-03 13:35, Manfred wrote:
> n4659 17.4 (Type equivalence) p1.3:
> 
> Two template-ids refer to the same class, function, or variable if
> ...
> their corresponding non-type template arguments of integral or
> enumeration type have identical values
> ...
> 
> It looks that for non-type template arguments the template type
> equivalence is based on argument /value/ not /type/ (and value), so
> IMHO gcc is correct where it considers foo<10u> and foo<10> to be the
> same type, i.e. "refer to the same class"
> 
> FWIW, type_info reports the same class name for both templates, which
> appears to be correct as per the above.
> 
> I would think someone from gcc might be more specific on why both
> templates print 4294967286, and what debug info is actually stored by
> -g in this case.

I think that Roman's example clearly shows that they are not equivalent in
all cases.

Building Roman's example with g++ 7.3 results in a single instantiated type.  You
can see that both "new foo<10>()" and "new foo<10u>()" end up calling the same
constructor.  It seems like which type is instantiated depends on which template
parameter (the signed or unsigned one) you use first.  So with this:

     base * fi = new foo<10>();
     base * fu = new foo<10u>();

the output is -10 for both, and with

     base * fu = new foo<10u>();
     base * fi = new foo<10>();

the output is 4294967286 for both.  But it's probably a bogus behavior.  I tested
with clangd, it instantiates two different types, so you get 4294967286 for the
<10u> case and -10 for the <10> case.  I also just built gcc from master, and it
also instantiates two types, so it seems like that was fixed recently.

So let's see what debug info gcc master generates for these two instances of foo
(clang master generates the equivalent).

  <1><9257>: Abbrev Number: 66 (DW_TAG_structure_type)
     <9258>   DW_AT_name        : (indirect string, offset: 0x8455): foo<10>
     <925c>   DW_AT_byte_size   : 16
     <925d>   DW_AT_decl_file   : 1
     <925e>   DW_AT_decl_line   : 7
     <925f>   DW_AT_decl_column : 8
     <9260>   DW_AT_containing_type: <0x92fd>
     <9264>   DW_AT_sibling     : <0x92f8>
...
 <1><93be>: Abbrev Number: 66 (DW_TAG_structure_type)
    <93bf>   DW_AT_name        : (indirect string, offset: 0x8455): foo<10>
    <93c3>   DW_AT_byte_size   : 16
    <93c4>   DW_AT_decl_file   : 1
    <93c5>   DW_AT_decl_line   : 7
    <93c6>   DW_AT_decl_column : 8
    <93c7>   DW_AT_containing_type: <0x92fd>
    <93cb>   DW_AT_sibling     : <0x945f>

If there are two types with the same name, how is gdb expected to differentiate
them?

If we can't rely on the DW_AT_name anymore to differentiate templated types, then
the only alternative I see would be to make GDB ignore the template part of the
DW_AT_name value, and reconstruct it in the format it expects (with the u) from the
DW_TAG_template_value_param DIEs children of DW_TAG_structure_type (there's already
code to do that in dwarf2_compute_name).  Their types correctly point to the signed
int or unsigned int DIE, so we have the necessary information.  However, that would
mean reading many more full DIEs early on, when just building partial symbols, which
would slow done loading the symbols of pretty much any C++ program.

>From what I understand from the original change that caused all this [1], removing
the suffixes was meant to make the error messages more readable for the user.
However, since foo<10>::print() and foo<10u>::print() are not the same function,
I think it would actually be more confusing if an error message talked about the
instantiation with the unsigned type, but mentioned "foo<10>::print()".  For example,
if you put a

  static_assert (std::is_signed<decltype(x)>::value);

in the print method, this is the error message from gcc:

  test.cpp: In instantiation of 'void foo<IVAL>::print() [with auto IVAL = 10]':
  test.cpp:24:1:   required from here
  test.cpp:12:22: error: static assertion failed
         static_assert (std::is_signed<decltype(x)>::value);
                        ^~~

Wouldn't the message make more sense with a u suffix?

Simon

[1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=78165


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]