This is the mail archive of the
mailing list for the GDB project.
Re: Request change name of function lookup_enum in libbabeltrace to make GDB use this lib
On Thu, Dec 6, 2012 at 6:51 PM, John Gilmore <firstname.lastname@example.org> wrote:
> I suggest that it's best if both GDB and Libbabeltrace change the name
> of lookup_enum. That way you'll be able to compile any version of GDB
> with any version of libbabeltrace (fixed or unfixed) and all four
> combinations will work except "unfixed GDB" and "unfixed
> If you just change it in the library, gdb stops building on machines that
> have the old library.
> If you just change it in GDB, older gdb's won't be compatible with
> newer libraries. Hmm, but older gdb's don't link with that library
> anyway. So you might as well just fix it in GDB; that works for all
Hi Tom, What do you think about the suggest from John?