This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: command-list does not work in my gdb 7.2 port

(gdb) b mainBreakpoint 1 at 0x40056c: file 1.c, line 3.(gdb) commands
Type commands for breakpoint(s) 1, one per line.End with a line saying
just "end".>shell echo 123>end(gdb) rStarting program:
Breakpoint 1, main () at 1.c:33	{123
Please try the trunk.


On Mon, Sep 26, 2011 at 22:58, Triple Yang <> wrote:
> Hi, everyone.
> I am making a gdb 7.2 port recently for a prototype architecture,
> which is a remote debug target in my case. The port is almost done to
> achieve my purposes, say:
> 1. Connecting to remote target and loading program image work well.
> 2. Control on the debugged program is OK.
> 3. Inserting/deleting breakpoints OK.
> 4. and so as some other basic facilities.
> But when I tried using gdb command "commands" to specify a command
> list after I set a breakpoint, I found this did not work at all. Here
> follows a rough example:
> (gdb) break main
> (gdb) commands
>>shell echo test-commands
> (gdb) run
> In this example, the command list is composed of only one command
> "shell echo test-commands". "test-commands" is expected to be output
> when the breakpoint is hit, but it does not happen. I tried replacing
> "shell echo test-commands" with other similar commands, it still did
> not work. but "shell echo" does work well when it is not used in a
> command list defined by "commands".
> I am not able to find any clue for this situation. Still worse, I can
> not provide sufficient information to gdb experts for analysis.
> I am hoping that someone who has ever met this problem before can help
> me with his/her invaluable suggestions.
> Thank you and best regards.
> --
> Yang Yong-Yong

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]