This is the mail archive of the
mailing list for the GDB project.
Re: [rfc] "reset" / "create-inferior" commands
- From: Joel Brobecker <brobecker at adacore dot com>
- To: Eli Zaretskii <eliz at gnu dot org>
- Cc: Daniel Jacobowitz <drow at false dot org>, gdb at sourceware dot org
- Date: Wed, 1 Nov 2006 16:11:00 -0500
- Subject: Re: [rfc] "reset" / "create-inferior" commands
- References: <20061101202811.GA20484@nevyn.them.org> <email@example.com>
> > Any comments on this name? I keep wanting the command, so I'd like to find
> > an acceptable name, and then I can go ahead and implement it.
> "restart" is good, IMHO. Some alternative names we might consider:
> reinvoke, start-again.
The only nit I have with "restart" is that it implies that something
is already running. But I presume that the command could be used when
no process has been started yet, right? I would have liked
"start-process", but then it creates a completion collision with
"create-process" sounds more accurate to me.