This is the mail archive of the
mailing list for the GDB project.
Re: [rfc] "reset" / "create-inferior" commands
- From: Eli Zaretskii <eliz at gnu dot org>
- To: Daniel Jacobowitz <drow at false dot org>
- Cc: gdb at sourceware dot org
- Date: Wed, 01 Nov 2006 22:37:25 +0200
- Subject: Re: [rfc] "reset" / "create-inferior" commands
- References: <20061101202811.GA20484@nevyn.them.org>
- Reply-to: Eli Zaretskii <eliz at gnu dot org>
> Date: Wed, 1 Nov 2006 15:28:11 -0500
> From: Daniel Jacobowitz <email@example.com>
> I haven't seen a good name which works for both scenarios. The best idea so
> far comes from Paul Brook - if we call the new command "reset", it's
> accurate for boards, and not terribly awkward for native processes.
> Alternatively, we could add two names for the command which did the same
> thing ("create-inferior" or "create-process" as an alias for "reset").
> [I would actually have picked "restart" over "reset", but that's taken for
> checkpoints. We could still steal it and use "restart checkpoint 1" for
> checkpoints, if others think restart is preferable to reset.]
> Any comments on this name? I keep wanting the command, so I'd like to find
> an acceptable name, and then I can go ahead and implement it.
"restart" is good, IMHO. Some alternative names we might consider: