This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Intel Xscale GDB

Hi all!
I am reposting this problem in case someone can help me.

I have a question about the source code of the Intel Xscale gdb
residing in the GNUPro toolkit source bundle.
I downloaded both versions (010413 and 010827) of the source code from
Intel's website
( and
tried to build them
on a RedHat Linux 7.1 machine (kernel 2.4.2-2, processor i686, gcc
version 2.96).
I have tried to build them on RedHat Linux 6.2 machine with egcs-2.91.66
i had no luck.

I am having problems compiling the gdb sources because of an error in
the directory src/gdb/i386-linux-nat.c line 102. A data type called
"gregset_t" is
not declared anywhere in any header file and this results in a
I can see that the "configure" program (in the gdb directory) checks
whether this type is declared in <sys/procfs.h> and it cannot find the
type gregset_t in this file.
In the file <sys/procfs.h> the only type that is similar to gregset_t
is called elf_gregset_t.

Does anyone have any idea how to solve this problem ?

thank you,

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]