This is the mail archive of the
mailing list for the GDB project.
Re: A copy/save command ...
> On Thu, Jan 03, 2002 at 04:02:37AM -0500, Andrew Cagney wrote:
>> better suggestions welcome.
> Perhaps not the best name - we want to be able to both read and write,
> and it's not clear which way copy goes. I don't want to end up doing
> magic thinking that ``this looks like an address, not a filename'' to
> figure that out.
Lets be honest, ``copy'' is a really bad name. For all those reasons
and probably more :-)
> Perhaps read/write? But that's still not clear which way is which.
> load/store would be perfect but load is already used.
store is interesting. Perhaps Michael's ``gcore'' command be called
store? Probably not since it is createing a core file and not an
executable. However as an alias it might make sense.
read/write are also interesting. Good documentation and a help message
should clarify the direction. With read, care would be needed since
``r'' is short for ``run''.