This is the mail archive of the gdb@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: enum enable


> breakpoint.h declares `enum enable'.  This gets in the way with some of 
> the DJGPP headers, because there's a library function by that name (which 
> enables interrupts).


I hit this when trying to fix some of the include header problems 
several years back.  Neadless to say I ducked the issue.


> Is it possible to rename the enum to something less general, such as 
> `enum bp_enable'?


My preference is for memattr.c to use ``int enabled_p'' and for 
breakpoint.h to use something like ``enum bp_state { bp_enabled, ...''.

	Andrew


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]