This is the mail archive of the
mailing list for the GDB project.
inferior_pid's magic value of zero.
- To: gdb at sourceware dot cygnus dot com (GDB Developers)
- Subject: inferior_pid's magic value of zero.
- From: Todd Whitesel <toddpw at windriver dot com>
- Date: Sun, 25 Mar 2001 01:17:09 -0800 (PST)
Would anyone object to patches that used a macro (say, NO_INFERIOR) instead
of the magic 0 that is currently used ?
Assuming the answer is yes, presumably we'd put the default #define to 0 in
inferior.h, and allow it to be overridden by tm.h.
toddpw @ windriver.com