This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Threading support with glibc 2.2 missing???

----- Original Message -----
From: Eugene Kuznetsov <>
To: <>
Sent: Wednesday, January 10, 2001 6:43 AM
Subject: Threading support with glibc 2.2 missing???

> Hello,
>       I was using gdb 5.0 with glibc 2.1.2 ( ix86 Linux ) for a long
>  time, and it worked pretty well for me. A few days ago I tried
>  to upgrade my system to glibc 2.2, which I supposed to be
>  stable. Immediately I discovered that I am no longer able to
>  debug anything multithreaded at all - command 'info threads' is
>  simply ignored, 'thread' shows information only about thread #0, and
>  when program crashes with segfault, I am shown the position where it
>  was in starting thread.

No. GlibC upgrading should be very cautious. GlibC2.0/2.1/2.2 are not
compitable definitely. If you upgrade GlibC2.0 to GlibC2.1, even some
commandline instructions will be invalid.

>      I tried compiling sources of gdb from ( I
>  suppose it was CVS snapshot from December 15th ). There things only
>  gotten worse ( now even 'thread' does not show any meaningful
>  information ).
>      What am I doing wrong? Is there anything I can do to get
>  debugging of multithreaded programs work again ( except reverting to
>  glibc 2.1.2/gdb 5.0, of course )?

Since you changed your basic system library, the conservative manner is to
rebuild your GDB and other applications. That sounds horrible.

>      Any help would be greatly appreciated.
> --
> Best regards,
>  Eugene                

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]