This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH v7.1] Support software single step on ARM in GDBServer.




On 12/11/2015 10:06 AM, Antoine Tremblay wrote:


On 12/11/2015 09:43 AM, Yao Qi wrote:
Antoine Tremblay <antoine.tremblay@ericsson.com> writes:

+  /* Assume all atomic sequences start with a ldrex{,b,h,d}
instruction.  */
+  insn1 = self->ops->read_memory_unsigned_integer (loc, 2,
byte_order_for_code);
+
+  loc += 2;
+  if (thumb_insn_size (insn1) != 4)
+    return NULL;
+
+  insn2 = self->ops->read_memory_unsigned_integer (loc, 2,
byte_order_for_code);
+

This line is too long, you may define a macro to shorten
"self->ops->read_memory_unsigned_integer".


This line is 79 long. From the GNU coding standard : "Please keep the
length of source lines to 79 characters or less"

So I think it's ok.

I'm not sure a macro is a good thing, it often makes the code harder to
parse for ides/emacs etc...

And I don't think shortening the lines is a good justification in
general for a macro.

How about I use a function pointer variable like :

ULONGEST (*read_memory_uint) (CORE_ADDR memaddr, int len, int byte_order);

read_memory_uint = self->ops->read_memory_unsigned_integer;

That would be already 23 shorter.

+  loc += 2;
+  if (!((insn1 & 0xfff0) == 0xe850
+        || ((insn1 & 0xfff0) == 0xe8d0 && (insn2 & 0x00c0) == 0x0040)))
+    return NULL;
+
+  /* Assume that no atomic sequence is longer than
"atomic_sequence_length"
+     instructions.  */
+  for (insn_count = 0; insn_count < atomic_sequence_length;
++insn_count)
+    {
+      insn1
+    = self->ops->read_memory_unsigned_integer (loc,
2,byte_order_for_code);
+      loc += 2;
+
+      if (thumb_insn_size (insn1) != 4)
+    {
+      /* Assume that there is at most one conditional branch in the
+         atomic sequence.  If a conditional branch is found, put a
+         breakpoint in its destination address.  */
+      if ((insn1 & 0xf000) == 0xd000 && bits (insn1, 8, 11) != 0x0f)
+        {
+          if (last_breakpoint > 0)
+        return NULL; /* More than one conditional branch found,
+                 fallback to the standard code.  */
+
+          breaks[1] = loc + 2 + (sbits (insn1, 0, 7) << 1);
+          last_breakpoint++;
+        }
+
+      /* We do not support atomic sequences that use any *other*
+         instructions but conditional branches to change the PC.
+         Fall back to standard code to avoid losing control of
+         execution.  */
+      else if (thumb_instruction_changes_pc (insn1))
+        return NULL;
+    }
+      else
+    {
+      insn2 = self->ops->read_memory_unsigned_integer
+        (loc, 2, byte_order_for_code);

Format looks wrong, multiple instances of this problem in the patch.


Yes actually I was not sure about that and discussed this with Pedro and
he agreed this was ok. That's why I went with that.

At some point when you have
if
   if
      if
         long_function_name (long variable,

And that does not fit you could have

         long_function_name (
        long variable, ... )

or      long_function_name
        (long variable, ...)

or ?

I went with the latter after discussion with Pedro but I'm open to
suggestions.

Possibly the change to function pointers variables would make this moot
but I think it may still happen.


I just tried to use indent for guidance on this (default gnu style)

and got this in the worst case :

insn2 =
  self->ops->
  read_memory_unsigned_integer
  (loc, 2, byte_order_for_code);

So while it did in the end put the function arguments below the function, it preferred splitting everywhere else before that.

I'm a bit surprised, however, that it has cut before = rather than after it, same surprise with -> ?

Honestly, however, I do think it's much clearer to write

insn2 = self->ops->read_memory_unsigned_integer
  (loc, 2, byte_order_for_code);

Then to split it up at = and ->

Ideas are welcome.

Thanks,
Antoine


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]