This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Make host_address_to_string/gdb_print_host_address cast parameter to 'void *'


On 27 October 2015 at 12:01, Pedro Alves <palves@redhat.com> wrote:
> Fixes a set of errors like:
>
>  ../../src/gdb/symfile-debug.c: In function âint debug_qf_map_symtabs_matching_filename(objfile*, const char*, const char*, int (*)(symtab*, void*), void*)â:
>  ../../src/gdb/symfile-debug.c:137:39: error: invalid conversion from âint (*)(symtab*, void*)â to âconst void*â [-fpermissive]
>         host_address_to_string (callback),
>                                         ^
>
> Note this has to work with data and function pointers.  In C++11 we
> may perhaps do something a bit safer, but we're not there yet, and I
> don't think it really matters.  For now just always do a simple
> C-style cast in host_address_to_string itself.  No point in adding a
> void * cast to each and every caller.
>
> gdb/ChangeLog:
> 2015-10-27  Pedro Alves  <palves@redhat.com>
>
>         * common/print-utils.c (host_address_to_string): Undef.
>         * common/print-utils.h (host_address_to_string): Add a wrapper
>         macro around the host_address_to_string function.
>         * utils.c ():

You can drop this last line.

>         * utils.c (gdb_print_host_address): Undef.
>         * utils.h (gdb_print_host_address): Add a wrapper macro around the
>         host_address_to_string function.
> ---
>  gdb/common/print-utils.c | 2 ++
>  gdb/common/print-utils.h | 4 ++++
>  gdb/utils.c              | 2 ++
>  gdb/utils.h              | 4 ++++
>  4 files changed, 12 insertions(+)
>
> diff --git a/gdb/common/print-utils.c b/gdb/common/print-utils.c
> index 1c1a5c1..bd62503 100644
> --- a/gdb/common/print-utils.c
> +++ b/gdb/common/print-utils.c
> @@ -315,6 +315,8 @@ core_addr_to_string_nz (const CORE_ADDR addr)
>
>  /* See print-utils.h.  */
>
> +#undef host_address_to_string
> +
>  const char *
>  host_address_to_string (const void *addr)
>  {
> diff --git a/gdb/common/print-utils.h b/gdb/common/print-utils.h
> index 8d16966..abeb003 100644
> --- a/gdb/common/print-utils.h
> +++ b/gdb/common/print-utils.h
> @@ -67,4 +67,8 @@ extern const char *core_addr_to_string_nz (const CORE_ADDR addr);
>
>  extern const char *host_address_to_string (const void *addr);
>
> +/* Wrapper that avoids adding a pointless cast to all callers.  */
> +#define host_address_to_string(ADDR) \
> +  host_address_to_string ((const void *) (ADDR))
> +
>  #endif /* COMMON_CELLS_H */
> diff --git a/gdb/utils.c b/gdb/utils.c
> index afeff12..101e438 100644
> --- a/gdb/utils.c
> +++ b/gdb/utils.c
> @@ -1103,6 +1103,8 @@ print_spaces (int n, struct ui_file *file)
>
>  /* Print a host address.  */
>
> +#undef gdb_print_host_address
> +
>  void
>  gdb_print_host_address (const void *addr, struct ui_file *stream)
>  {
> diff --git a/gdb/utils.h b/gdb/utils.h
> index 995a1cf..a226744 100644
> --- a/gdb/utils.h
> +++ b/gdb/utils.h
> @@ -248,6 +248,10 @@ extern int filtered_printing_initialized (void);
>  /* Display the host ADDR on STREAM formatted as ``0x%x''.  */
>  extern void gdb_print_host_address (const void *addr, struct ui_file *stream);
>
> +/* Wrapper that avoids adding a pointless cast to all callers.  */
> +#define gdb_print_host_address(ADDR, STREAM) \
> +  gdb_print_host_address ((const void *) ADDR, STREAM)
> +
>  /* Convert CORE_ADDR to string in platform-specific manner.
>     This is usually formatted similar to 0x%lx.  */
>  extern const char *paddress (struct gdbarch *gdbarch, CORE_ADDR addr);
> --
> 1.9.3

I'm not a fan of the #undef, it makes it harder to follow what's
happening.  Why not just rename the existing function to
host_address_to_string_1?

Same for gdb_print_host_address.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]