This is the mail archive of the
mailing list for the GDB project.
Re: [PATCH 2/2] handle an unspecified return address column
- From: Mark Kettenis <mark dot kettenis at xs4all dot nl>
- To: brobecker at adacore dot com
- Cc: tromey at redhat dot com, gdb-patches at sourceware dot org
- Date: Tue, 26 Nov 2013 15:30:15 +0100 (CET)
- Subject: Re: [PATCH 2/2] handle an unspecified return address column
- Authentication-results: sourceware.org; auth=none
- References: <1384375873-32160-1-git-send-email-tromey at redhat dot com> <1384375873-32160-3-git-send-email-tromey at redhat dot com> <20131126133446 dot GA28596 at adacore dot com> <201311261348 dot rAQDmBs1032481 at glazunov dot sibelius dot xs4all dot nl> <20131126135519 dot GI3114 at adacore dot com>
> Date: Tue, 26 Nov 2013 17:55:19 +0400
> From: Joel Brobecker <email@example.com>
> > > gdb/ChangeLog:
> > >
> > > PR backtrace/16155:
> > > * dwarf2-frame.c (dwarf2_frame_cache): Remove condition that
> > > sets cache->undefined_retaddr to 1 if there is no column in
> > > the frame info for the return register.
> > >
> > > Tested on x86_64-linux, no regression. It also fixes all regressions
> > > observed on arm-elf and ppc-elf.
> > >
> > > Can you tell me what you think?
> > Please start with backing out the original change.
> I would gladly do so, but can you explain the rationale behind your
> request? Is it to facilitate review of this patch? Or is it because
> you think all of the original patch needs to go? I felt that the patch
> just overachieved a bit from what it initially set out to do (detect
> unspecified return registers), and so I felt it was ok to send a
> followup rather than redo it entirely.
Pretty much both. The original diff was clearly wrong, and it is best
to have the history reflect that clearly. But it will also make the
review easier. To be honest, I think the conditional, after your
modification, is too confusing.
Didn't realize that the tests were part of the same commit though. So
you probably can't simply use git revert. Perhaps that means we
should commit testsuite changes seperately in the future.