This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: RFA: [Ada] extract known tasks array parameters from symbol table


> here is the new version, taking into account your comments:  I have
> mostly reshaped ada_set_current_inferior_known_tasks_addr, tell me if
> the new form is ok (and then I will test it more thoroughly).

Overall, that looks good to me. I see what you mean in terms of
supporting the stripped runtime (this near duplication is ugly),
but I don't see an efficient way to avoid it.

Just one minor comment:

> @@ -865,27 +848,95 @@ get_known_tasks_addr (const char *name)
>  static void
>  ada_set_current_inferior_known_tasks_addr (struct ada_tasks_inferior_data *data)

I would change the name of the function since it's doing more and more
than just setting the address. Something like "set_ada_tasks_inferior_data"
for instance, or maybe "ada_tasks_inferior_data_sniffer", etc.

Can you also update the comment to just say that it sets all fields in
DATA instead of specifying each one? It's a bit more vague, but still
true nonetheless, and will avoid having to update the comment if we add
new fields again in the future.

Thank you!
-- 
Joel


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]