This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[RFA] target record_core -> target record-core?


I realize this is a nit but is it possible to rename
target record_core to target record-core?
Or is it too late ...

All other targets (that I know of) use dashes in shortname, and having
to remember which use dashes and which use underscores is, umm, blechy.
[Unless we have and enforce a convention, it can only get worse,
so might as well establish one now - if it doesn't exist already.]

2010-04-18  Doug Evans  <dje@sebabeach.org>

	* record.c (init_record_core_ops): Rename record_core to record_core.

Index: record.c
===================================================================
RCS file: /cvs/src/src/gdb/record.c,v
retrieving revision 1.44
diff -u -p -r1.44 record.c
--- record.c	8 Mar 2010 13:34:38 -0000	1.44
+++ record.c	19 Apr 2010 06:44:51 -0000
@@ -1863,7 +1863,7 @@ record_core_has_execution (struct target
 static void
 init_record_core_ops (void)
 {
-  record_core_ops.to_shortname = "record_core";
+  record_core_ops.to_shortname = "record-core";
   record_core_ops.to_longname = "Process record and replay target";
   record_core_ops.to_doc =
     "Log program while executing and replay execution from log.";


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]