This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch 0/1] Threaded Watchpoints


On Mon, Sep 10, 2007 at 08:44:22PM +0200, Ulrich Weigand wrote:
> I guess your new way makes more sense.  This means we can remove
> HAVE_CONTINUABLE_WATCHPOINTS completely, though.  (As a related
> point, I think it would be good to fix the oddity that nonsteppable
> watchpoints are reported as a gdbarch property while steppable
> watchpoints are reported as a target property ...)

I totally agree.  I just don't know which one makes more sense.
Probably gdbarch but I'm sure I'll break something if I try to
change it.

> > > This assumes that the new thread's ptid will always be passed to the
> > > resume.  Is this necessarily the case?  I would expect ptid to be -1
> > > in most cases ...
> > 
> > It is necessarily the case.  This function is never called through
> > target_resume, only through linux_nat_resume.  This was one of the big
> > cleanups that made my patch possible.
> 
> Hmm, I see.  This assumes that after every new-thread event, the new
> thread is selected as inferior_ptid, though.

I don't think it assumes that.  s390_resume should be called once for
each thread, and not depend on inferior_ptid at all; only
linux_nat_resume has to check for ptid == -1, schedlocking, et cetera.

-- 
Daniel Jacobowitz
CodeSourcery


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]