gdb-patches archive
subject index for October, 2004

This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

[cobish] Don't set in_solib_call_trampoline to in_plit_section

[commit Eliminate t_insn

[commit/CRIS] Dwarf-2 and sigtramp frame unwinder (and more)

[commit/CRIS] Re-add core file functions

[commit/m32r] revised m32r-linux patch

[commit/mips] Delete after_prologue

[commit/mips] Enum renames

[commit/mips] makes [mips_]pc_is_mips16 public

[commit/mips] Move mdebug code to own file, don't enable

[commit/mips] Remove old style struct return code

[commit/mips] Simplify print_insn

[commit/mips] use add_setshow_zinteger_cmd

[COMMIT/TESTSUITE] Add mips*-*-netbsd* to list of NetBSD/ELF targets in asm-source.exp

[COMMIT] *BSD/i386 a.out shared library cleanups

[commit] A tip for using less memory for symtabs

[COMMIT] Accept "\r\n" line-endings on all hosts

[commit] Accumulated changes to Ada sources

[COMMIT] Ada updates

[commit] Add add_setshow_enum_cmd, use in mips

[commit] Add attr format, and fixme

[commit] Add error-message parameter to get_selected_frame

[commit] Add MIPS_EMBED...

[commit] Add MIPS_PS_REGNUM

[commit] Add SINGLE_STEP_THROUGH_DELAY

[COMMIT] Add support for OpenBSD/hppa system call stubs

[commit] Always build inf-child.o

[commit] Clean up mips_dump_tdep

[COMMIT] Cleanup mipsread.c

[commit] Cleanup parse_frame_specification

[COMMIT] Cleanup proc-events.c

[COMMIT] Convert *BSD/sparc* to use target vector inheritance

[commit] corrections in comments

[COMMIT] Default to using "b" in fopen()

[commit] Delete gdbarch in_solib_call_trampoline

[commit] Delete generic_in_solib_call_trampoline

[commit] Delete MIPS in_solib_return_trampoline hack

[commit] Delete MIPS only DEPRECATED_IGNORE_HELPER_CALLER

[commit] Delete MIPS RA_REGNUM

[commit] Delete SETUP_ARBITRARY_FRAME

[commit] Delete unused variable/defn

[commit] Document "info proc" subcommands

[commit] Don't include intl/ and utils/ in distro

[COMMIT] Don't use DEPRECATED_FP_REGNUM in procfs.c

[commit] Eliminate a deprecated_read_register_gen call

[commit] Eliminate HPPA's IN_SOLIB_CALL_TRAMPOLINE

[commit] Eliminate MIPS HIGH_ADDR and FRAME_ADJUST

[COMMIT] Fix coding style in some dwarf2read.c fragments

[COMMIT] Fix coding-style issues in proc-why.c

[COMMIT] Fix compiler warnings in ada-lang.c

[commit] Fix djunpack.bat nit

[commit] Fix flex options

[COMMIT] Fix GNU/Linux UltraSPARC (hopefully)

[commit] Fix info frame's saved registers output

[COMMIT] Fix procfs_xfer_partial

[COMMIT] Fix SPARC Linux

[commit] Fix xfer-partial edge cases

[commit] Garbage collect tm-mips.h, it's empty

[COMMIT] Make GNU/Hurd native build again

[COMMIT] Make solib-sunos.c more self-contained

[commit] malloc and sys/wait.h tweaks

[commit] MIPS_PRID_REGNUM

[COMMIT] Modernize NetBSD/mips core file handling

[Commit] Obvious fix for compilation failure.

[COMMIT] OpenBSD/mips64 target and native support

Re: [commit] Prefer xfer_partial for memory xfers

[COMMIT] Prepare Solaris x86 for 64-bit Solaris 10

[commit] Properly remove a warning message caused by ada-lex.l

[COMMIT] Rationalize O_BINARY usage in source.c

[COMMIT] Really disable TUI if curses is missing

[COMMIT] Remove redundant protype in mips-tdep.c

[commit] s/mips_/mdebug_/

[COMMIT] Some coding style cleanups in procfs.c

[COMMIT] Target vector inheritance for NetBSD/mips

[commit] Turn on initial Ada support in GDB (Part 1)

[COMMIT] Undeprecate sparc-linux-tdep.c

[commit] Update NEWS

Re: [commit] Use full paths for "info sources"

[commit] Zap more tm-mips.h macros

[commit]: Documentation for initial Ada support in GDB

[commit]: Turn on initial Ada support

[committed] Merge libtool support for s390x-ibm-tpf

[gdbserver] Add NPTL support

[gdbserver] Use -rdynamic where possible

[ob] Move extern ecoff_relocate_cfi to mdebugread.h

[obish] Cleanup MIPS SKIP_TRAMPOLINE_CODE

[obish] Delete ecoff_relocate_efi

[obish] Don't set in_solib_call_trampoline to generic_...

[obish] fix target.c build probs

[obish] IN_SOLIB_RETURN_TRAMPOLINE cleanups

[obish] Move MDEBUG_EFI_SYMBOL_NAME out of tm-*.h

Re: [obish] Move s/w single-step to mips-linux-tdep.c

[obish] Zap more complex non-sets of in_solib_call_trampoline

[Obvious] Update my e-mail address

[oops] Tweak mdebugread.c to still build

[PATCH/mips] merge mips16_skip_prologue into mips16_scan_prologue

[PATCH/mips] mips16 frame code simplification

[PATCH/mips] Remove 2 unused functions

[patch/mips] rename mips16/32_heuristic_proc_desc

[PATCH/mips] replace some calls to heuristic_proc_desc

[patch/mips] small cleanup (unused variables, comments, etc)

[PATCH/mips] small code reordering...

[PATCH/RFA] Add some constants in mips-tdep.h

[PATCH/RFA] First stab at cleaning up tm-mips.h

[PATCH/RFA] Remove high_addr from mips_extra_func_info for MIPS

[PATCH/RFA] Set tramp_frame unwinder type correctly

[PATCH/RFA] Use runto_main and continue instead of run

[patch/rfc] Build inf-ptrace.o when ptrace available

[patch/rfc] Check that "info frame" doesn't change

Re: [patch/rfc] Deprecate child_ops global

[patch/rfc] Deprecate sym_private, obj_private, and sym_stab_info

[patch/rfc] Deprecate to_xfer_memory

[patch/rfc] Obsolete d10v

[patch/testsuite/copyright] gdb.base/overlays.exp: update with 2004

Re: [patch;rfa:doc] 5.2.50 on mainline

[PATCH] comment spelling corrections

[PATCH] Fix build failure m32r-linux-run

[PATCH] Fix s390 problems with current GCC

[PATCH] Fix small typo in symtab.h

[PATCH] ia64-linux-nat.c: Eliminate references todeprecated_registers[]

[patch] Makefile.in: fix xmalloc substitution

[PATCH] Minor reformatting in symtab.c

[patch] New test for set backtrace related functionality

[PATCH] rs6000-tdep.c: Eliminate references todeprecated_registers[]

[PATCH] Seg fault whilst stepping when watch set

Re: [PATCH] Seg fault whilst stepping when watch set [ping!]

Re: [PATCH] SH 2a - Part 1: Basic cpu type and register handling

[PATCH] sh-tdep.c: Rename store/extract functions for better readability (was Re: [PATCH]: SH 2a - Part 4: Begin using RETURN_VALUE)

[PATCH] sim build failure to use ENDSWITCH macro with gcc-3.4.2

[patch] typo in gdb/testsuite/config/gdbserver.exp

Re: [PATCH]: SH 2a - Part 2: Prologue and epilogue analyzing

Re: [PATCH]: SH 2a - Part 3: Bank register handling

Re: [PATCH]: SH 2a - Part 4: Begin using RETURN_VALUE

[RFA/dwarf2] Fix name of include psymtabs, avoid duplicates

[RFA/dwarf2] Set language to Ada for Ada compilation units

[RFA/dwarf2] Use SYMBOL_SEARCH_NAME to set type name

Re: [rfa/dwarf] Fix a line table bug

Re: [rfa/dwarf] Support for attributes pointing to a different CU

[RFA/m32r] Fix breakpoint bug

[RFA/m32r] Fix m32r frame analyzer

Re: [RFA/m32r] revised m32r-linux patch

[RFA/m32r] set return_value

[RFA/m32r] Unreviewed patch (breakpoint bug)

[RFA/mips] merge mips32_skip_prologue into mips32_scan_prologue

[RFA/mips] Remove mips16 code that seems redundant

Re: [RFA/PATCH/mips16] Remove dead code in mips_insn16_frame_cache

[RFA/testcase] Enable overlays.exp only for sim target

[RFA/testcase] fix compile error of asm-source.exp for m32r-linux

[RFA/testsuite/ada] Refine expected output of start command

[RFA/testsuite] Stop sharing .c file between 2 testcases

[RFA] Add parse_dwarf2_calling_convention functionality

[rfa] Attach vsyscall support for GNU/Linux

[RFA] Change gdbarch_return_value to take function type instead of return value type

Re: [RFA] Change gdbarch_return_value to take function type insteadof return value type

[RFA] Don't apply line-number tweaks for non-GCC compilers

[rfa] dwarf2 intercu test

[rfa] Dwarf2 testsuite

[RFA] dwarf2read.c: Use make_function_type instead of lookup_function_type

[rfa] Fix remote debugging

[RFA] gdbtypes.h: Add "calling_convention" field to struct main_type

[RFA] Improve "start" command for Ada

[rfa] Include the LWP in thread-db's PTIDs

[RFA] infcall.c: Use correct macro

[RFA] initialize err variable in load_section_callback()

[RFA] Make solib-sunos.c more self-contained

[RFA] ppc/rs6000: use gdbarch_ps_regnum

[rfa] qSymbol in remote_wait

[RFA] Setting long long bitfields

[RFA] sh-tdep.c: Begin evaluating calling_convention

[RFA] sh-tdep.c: Implement calling convention specific argument passing

[RFA] sh-tdep.c: Introduce extracting struct value

[RFA] sh-tdep.c: parse_dwarf2_calling_convention function

[RFA] sh-tdep.c: Use calling convention ifo in use_struct_convention

[RFA] stabs: octal negative numbers

[RFA] Testcase for \r\n in command files

Re: [RFA]: Change to_stopped_data_address ABI

Re: [RFA]: Fix to watchthreads test case

[RFA]: issue warnings for frame offenses

[RFA]: Remove warnings from ada-exp.tab.c compilation

Re: [RFA]: Turn on initial Ada support in GDB

[RFA]: Watchpoints per thread patch

[RFC/mips] Proposal for inlining heuristic_proc_desc a bit...

[rfc/NEWS] GDB works with GCC -feliminate-dwarf2-dups.

[RFC] Calling mips-tdep.c:read_next_frame_reg with null frame?

[RFC] net testcase for set backtrace related functionality

Re: [testsuite] Add test for setting breakpoints by full path

Re: backtrace changes current source location

EN|1lARGE Y0UR P^E^N^IS 1N A WEEKI||1lY!

Fetishes

Fix aliasing violations

Fix bfd_close for BFD_IN_MEMORY

fix for crash in dwarf2read.c

Fix missing declaration

Re: gcore or generate-core-file command?

GDB 6.3 branch available

gdbserver build broken on amd64-linux

gutted

an i18n sample

kgdb support for gdb

MIPS/Linux: Single-stepping running away

Patch to support AMD64 Solaris 10

PATCH: fix some remaining uses of child_ops

Re: Patch: Handle relative paths in .debug_line

PATCH: Step down from maintainerships

Ping: Re: testcase for "absolute source" patch

possible inclusion of Jim's recent "p" packet fix in 6.3 branch?

RFA: adapt gdb.threads/linux-dp.exp to remote protocol and NPTL

RFA: Adapt linux-dp.exp to NPTL with debugging info

RFA: fix formatting of 'p' packet register number

RFA: remote.c: parse thread ID's as unsigned values

RFA: Update sim-defs.exp to support the rawsid protocol

RFC: The Constructor Breakpoint Issue

Re: STEP_SKIPS_DELAY question, sort of

testsuite fixes for bleeding edge gcc


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc 2.6.3