This is the mail archive of the gdb-patches@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFC] s/UINT_MAX/GDB_UINT_MAX/ ?


On Wed, Aug 11, 2004 at 03:46:40PM -0700, Joel Brobecker wrote:
> This is the last entity in config/powerpc/xm-aix4.h. The comment says:
> 
> /* UINT_MAX is defined in <sys/limits.h> as a decimal constant (4294967295)
>    which is too large to fit in a signed int when it is parsed by the
>    compiler, so it issues a diagnostic.  Just undef it here so that we
>    use gdb's version in defs.h */
> #undef UINT_MAX
> 
> So we have a collision between the macro defined by GDB and the macro
> defined by the system. For recent enough versions of AIX, I don't think
> the values are different, so we could look the other way and just remove
> the #undef, and all things should work. But we still have this collision
> and I think we should fix it.
> 
> So I suggest we do an all-source rename of UINT_MAX et al to GDB_UINT_MAX,
> or something like this. Unless the collision was expected (ie we want to
> pick the system value when defined)?

The latter is correct.  Take a look at the definition, in defs.h.

That's a buggy system... if you want to support it, we should detect it
in autoconf.  Otherwise, I doubt we'll really miss the #undef.

-- 
Daniel Jacobowitz


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]