This is the mail archive of the gdb-patches@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: RFA: Breakpoint infrastructure cleanups [1/8] - define impl_breakpoint


> Date: Wed, 8 Oct 2003 13:02:33 -0400
> From: Daniel Jacobowitz <drow@mvista.com>
> +
> +enum impl_bptype
> +{
> +  impl_bp_software_breakpoint,
> +  impl_bp_hardware_breakpoint,
> +  impl_bp_hardware_watchpoint,
> +  impl_bp_other			/* Miscellaneous...  */
> +};

Why did you decide to leave the subclasses of hardware watchpoints
(read, access, and write) in the parent structure, instead of moving
that distinction here?  That seems like you are spreading related
information between several places instead of having it in a single
place.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]