gdb-patches archive
subject index for May, 2003

This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

$ cvs update -d gdb/testsuite/gdb.objc

[ cagney_fileio-20030521-branch] New branch

[applied sim patch] tweak some attributions slightly.

[BFD PATCH] Fix QNX Neutrino core file reading

[BFD PATCH] grok NT_AUXV note in ELF core files

[branch patch] core files as symfiles

[branch patch] dwarf-frame.c support for .eh_frame_hdr

Re: [Bug-dejagnu] [dejagnu patch] tweak conditional_xfail empty 'includes' list behaviour

[commit/multiarch/hppa] A bit of code shuffling...

Re: [commit/multiarch/hpux] hppa32 is now partially multiarched

[commit] [avr] Add breakpoint-from-pc gdbarch method.

[commit] Add frame_align to d10v.

[commit] Add regcache parameter to translate xfer address method

[commit] Always call DEPRECATED_FIX_CALL_DUMMY :-(

[commit] Always define the macros (when not defined)

[commit] Convert mips to print_registers_info

[commit] Convert MIPS to push_dummy_call

[commit] DavidC old patch

[commit] Drop REGISTER_SIZE, REGISTER_BYTES, PC_REGNUM from d10v

[commit] Eliminate deprecated_grub_regcache_for_register_valid

[commit] Eliminate prev_func_name global

[commit] file name et.al. probs

[commit] fix ia64 and avr uses of translate xfer address

[commit] Fix objc-lang.c on IRIX CC problems

[commit] generic_find_dummy_frame -> deprecated_find_dummy_frame_regcache

[commit] hpread.c cleanups

[commit] MAX_REGISTER_RAW_SIZE -> MAX_REGISTER_SIZE

[commit] max_register_size() -> MAX_REGISTER_SIZE

[commit] MAX_REGISTER_VIRTUAL_SIZE -> MAX_REGISTER_SIZE=16

[commit] minor mips arch cleanups

[commit] Move signed register reads to mips-tdep.c

[commit] s/extract_address/.../ for *lang*

[commit] s/extract_address/extract_unsigned_integer/ some

[commit] Update my email address.

[commit] Use "pc" when there isn't a PC_REGNUM

[dictionary] calculate names for class psyms correctly

[dictionary] determine type name correctly via cross-references

[dictionary] fiddling with the parser

[dictionary] fix bug in decode_compound

[dictionary] fix calls to lookup_minimal_symbol

[dictionary] handle anonymous classes/structs

[dictionary] lookup_transparent_type

[dictionary] merge with mainline

[dictionary] tests for RTTI warning

[dictionary] testsuite tweaks

[fileio] I checked in corinna's patch

Re: [i386newframe/PATCH] New i386newframe branch

[i386newframe]: Merge from mainline

Re: [just for the record]: new prologue analyzer for S/390

[ob] Delete STARTUP_INFERIOR

[ob] Eliminate some extern's in .c

[ob] Fix sparc build

[ob] Use @{ and @} in doco

[patch rfc, rfa:doco] Eliminate BREAKPOINT, BIG_BREAKPOINT, LITTLE_BREAKPOINT

[patch rfc, rfa:doco] Working on-stack generic dummy frames

[patch rfc] "maint print dummy-frames" command

[patch rfc] Add func_addr param to push_dummy_call

[patch rfc] Add gdb_print_insn (eliminate many tm_print_insn_info)

Re: [patch rfc] Always disassemble the target

[patch rfc] Deprecate REGISTER_BYTES

[patch rfc] Dummy deprecate deluge

[patch rfc] Eliminate extract_address

[patch rfc] Gag gdb_assert related const condition warning

[patch rfc] s/extract_address/extract_unsigned_integer/ for solib

[patch rfc] store_address -> store_unsigned_integer

[patch/commit] rename 'mangled_name' to 'linkage_name'

[PATCH/i386newframe/RFC] DWARF CFI frame unwinder

[PATCH/i386newframe]

[PATCH/i386newframe] Add and fix some comments

[PATCH/i386newframe] Add asssertion to CFI frame unwinder

[PATCH/i386newframe] Add support for .eh_frame sections

[PATCH/i386newframe] amd64newframe

[PATCH/i386newframe] Correctly find PC in %eax if appropriate

[PATCH/i386newframe] Don't throw away the cache on amd64

[PATCH/i386newframe] Don't use the DWARF CFI frame base methods

[PATCH/i386newframe] Fix amd64 stack frame base address

[PATCH/i386newframe] Fix comment

[PATCH/i386newframe] Fix problems with Linux/i386 and Linux/x86-64

[PATCH/i386newframe] Fix QNX/Neutrino

[PATCH/i386newframe] Fix REG_SAVED_REG register rule

[PATCH/i386newframe] Fix return address column handling

[PATCH/i386newframe] Fix x86_64 shared lib botch

[PATCH/i386newframe] Fix x86_64_linux_sigcontext_addr

[PATCH/i386newframe] Get rid of DEPRECATED_FP_REGNUM

[PATCH/i386newframe] Indentation fix

[PATCH/i386newframe] OB: fix comment

[PATCH/i386newframe] Remove call to inside_entry_file

[PATCH/i386newframe] Rename DWARF CFI functions

[PATCH/i386newframe] Replace extract_address

[PATCH/i386newframe] Seperate signal trampoline unwinder

[PATCH/i386newframe] Some cleanups in i386-specific files

[PATCH/i386newframe] Some i386-tdep.c fixes

[PATCH/i386newframe] Some tweaks

[PATCH/i386newframe]: Remove usage of FP_REGNUM

[PATCH/RFA] Always use $(SHELL) when invoking move-if-change

[PATCH/RFA] Fix size_t related problems in dwarf2loc.c

[PATCH/RFA] Incorrect call to memset in ppc/sim/hw_nvram.c

[PATCH/RFA]: Use opcodes VAX disassembler

Re: [PATCH/RFC] charset.c/charset.exp/doco updates

[PATCH/RFC] Fix asm-source.exp on FreeBSD

Re: [PATCH] new support for PPC64 architecture

[PATCH] (dagnabbit) QNX Neutrino i386 support

[PATCH] [m32r-elf ] m32r-stub.c compile error with gcc-3.3

[PATCH] A small cleanup in blockframe.c

[PATCH] Add DWARF CFI frame unwinder

[patch] Add REGISTER_BYTE_P, check consistency

[PATCH] add-symbol-file-from-memory command

[patch] allocate name of anonymous objfiles properly

[patch] copyright notice correction on libiberty/make-relative-prefix.c

Re: [PATCH] core files as symfiles

[PATCH] Fix "info float" test on amd64

[PATCH] Fix amd64 compilation

[PATCH] Fix GNU/Hurd build error

[PATCH] Fix i386 MMX register name printing

[PATCH] Get rid of I386_GNULINUX_TARGET

[PATCH] Hook in DWARF CFI frame unwinder on i386 and amd64

[PATCH] i386/amd64 check sigcontext_addr handler

[PATCH] Improvements to Fortran support

[PATCH] Include "gdb_string.h"

[PATCH] Large array fix for Fortran.

[PATCH] Merge amd64 parts of i386newframe into mainline

[PATCH] Merge parts of i386newframe into mainline

[PATCH] mips-nat.c: Convert REGISTER_PTRACE_ADDR into a function

[PATCH] multi-arching m32r

[Patch] Native QNX Neutrino support

[patch] new tests gdb.c++/rtti.exp

[PATCH] Prepare i387_supply_fxsave for use by x86-64.

[PATCH] Pretty print value.h

[patch] QNX core file reading fix

[patch] remove pointless call.

[patch] remove stray comment

[PATCH] Remove unnecessary casts in i386-linux-nat.c

[PATCH] Rename *_NAMESPACE enum

[PATCH] Rewrite sparc32 argument pushing

[PATCH] rs6000-tdep.c: Improve prologue analysis of 64-bit code

[PATCH] Snatch more registers from amd64 sigcontext

[PATCH] Snatch more registers from i386 sigcontext

[PATCH] some cleanups in stabsread.c

[PATCH] Some sparc undeprecation

[patch] typo in valops.c

Re: [PATCH]: Use opcodes VAX disassembler

Re: [PING/RFA]: Search for Objc Symbols

[ppc64-linux] Cope with non-existent MQ register

[ppc64-linux] Disable asm-source test on powerpc64-*-linux*

[ppc64-linux] Give correct type for ptrace values

[ppc64-linux]: Add basic native configury

[ppc64-linux]: Support gdbserver on PPC64 Linux

[RFA/i386newframe] info cfi command

[rfa/rfc/testsuite] default.exp and minimal language

[RFA/RFC] Problem with '!' escaping with zsh/bash/ksh

[rfa/testsuite] add test embryo for lang = minimal

Re: [rfa:doco] Delete references to extract_address and store_address in doco

Re: [rfa:doco] Delete references to extract_address and store_address in doco

[rfa:doco] Delete references to extract_address and store_addressin doco

[rfa:doco] Doco problems with level two annotations

[rfa:doco] update for annotate level three

[RFA] Add new language: "unsupported"

[RFA] alpha frame unwind tweakage

[RFA] Correct double negative in gdbint.texinfo

Re: [RFA] dwarf2expr.c: Fix some stack [re]allocation problems

Re: [RFA] dwarf2expr.c: Prepare for eventual DW_OP_piece support

[RFA] Fallback unsupported languages to "minimal"

[RFA] gdb.asm/alpha.inc

[RFA] H8/300sx port for gas, sim, and opcodes (1/5)

[RFA] H8/300sx port for gas, sim, and opcodes (2/5)

[RFA] H8/300sx port for gas, sim, and opcodes (3/5)

[RFA] H8/300sx port for gas, sim, and opcodes (4/5)

[RFA] H8/300sx port for gas, sim, and opcodes (5/5)

[rfa] Inline/eliminate DEPRECATED_SYMBOL_MATCHES_NAME

[rfa] language hooks for lookup_symbol

[RFA] Limited DW_OP_piece support

[rfa] linespec.c: add_{matching_methods,constructors}

[RFA] MIPS: Introduce struct mips_regnums and accessors

[RFA] MIPS: MIPS_LAST_FP_ARG_REGNUM, MIPS_LAST_ARG_REGNUM changes

[rfa] namespace scope, take 2

Re: [RFA] new GDB/MI command: -symbol-info-linetable

[RFA] new mi-symbol.exp file for GDB/MI cmd: -symbol-info-linetable

[rfa] remove unused variable

Re: [rfa] struct dictionary

Re: [rfa] teach lookup_symbol about namespace scope

[RFA] x86-64 ABI change

Re: [RFA]: File-I/O patch, testsuite

[RFA]: gdbarch FETCH_POINTER_ARGUMENT

Re: [rfc breakpoint] Catch exceptions

[RFC/i385newframe] Fix sigtramp unwinder.

[RFC/i386newframe] Restore all registers from sigframe

[RFC/RFA] HPUX: Remove (non-useful?) definition of PREPARE_TO_PROCEED

[RFC] -mi-level command

[RFC] dwarf2_compose_register_pieces for the e500

[RFC] frame-ify the alpha port

[RFC]: Remove CONVERT_FUNCPRT from objc-lang.c

[TOP LEVEL PATCH] configure.in: Remove newlib/libc/sys/cygwin dirs from FLAGS_FOR_TARGET

Re: [toplevel patch] Macroize build_subdir & target_subdir, newest version

[toplevel patch] rename autogen variable in Makefile.tpl,Makefile.def

[WIP/RFC] MIPS registers overhaul

[WIP/RFC] MIPS registers overhaul [clarification]

[wip] Annotation level 3

Always remote: [WIP/RFC] MIPS registers overhaul

ATTENTION: gdb-patches

bfd function to read ELF file image from memory

Re: build/955: build failure with GDB-5.3: sparc-nat.c structure redefinition errors with sparc64-linux, glibc-2.2.x

Compile fix for target m68k-linux

congratulation

Correct memset calls in ser-{pipe,tcp,unix}.c

Fix parameter passing on m68k

Fix readline for platforms without <wchar.h>

gdbtk: Patch for terrible slow stepping

Kill reduce/reduce conflicts

More multi-arch and cleanups for m68k-linux

Multi-arch m68k-linux

PATCH/RFA: Disassembler mixes filtered and unfiltered output

PATCH/RFA: Ping on disassembler mixes filtered and unfiltered output

PATCH: Accept i786 variant

PATCH: Add myself to MAINTAINERS write after approval list

PATCH: Correct memset calls in ser-{pipe,tcp,unix}.c

PATCH: Fix PR 1171

PATCH: gdb.base/corefile.exp: tolerate stuff after argument parens

PATCH: Include more files in snapshots/releases

PATCH: Make sure gdb-cfg.texi is created

PATCH: Use $(SHELL) when running mkinstalldirs

PREPARE_TO_PROCEED; Was: More multi-arch and cleanups for m68k-linux

Re: PREPARE_TO_PROCEED; Was: More multi-arch and cleanups form68k-linux

proposed PATCH: make watchpoints work correctly

Re: RFA/RFC: dump symtab and psymtab lists

RFA: dwarf2read.c patch

Re: RFA: asm-source.exp: use switch instead of if chain

RFA: doc: update 'dump' documentation

RFA: don't cast last argument to ptrace

RFA: ia64 prologue skipping patch

RFA: Linux gdbserver: store register values with proper type

Re: RFA: nptl threading support for linux-dp.exp

Re: RFA: nptl threading support for schedlock.exp

RFA: patch to infptrace.c

RFA: use gdbarch for solib stuff on PPC Linux

Re: RFC: Add support for s390x to asm-source.exp

Re: RFC: coffread.c relocation fixes

RFC: find core dumps on Linux

RFC: New failure in asm-source.exp

Re: RFC: nptl threading patch for linux

RFC: patch to refresh prev_pc

RFC: s390x: correct core file register layout

Re: RFC: threads PREPARE_TO_PROCEED patch

Re: sim/testsuite/sim/testsuite/*.*.*

Toplevel configury patch 1/n (general cleanup/rearrangement)

TOPLEVEL PATCH: accept more x86 variants


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc 2.6.3