This is the mail archive of the gdb-patches@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [rfa] rename insight to insight


On Aug 26,  2:29pm, Grace Sainsbury wrote:

> -int
> -main (int argc, char **argv)
> -{
> -  struct captured_main_args args;
> -  args.argc = argc;
> -  args.argv = argv;
> -  catch_errors (captured_main, &args, "", RETURN_MASK_ALL);
> -  return 0;
> -}
> +/*  int */
> +/*  main (int argc, char **argv) */
> +/*  { */
> +/*    struct captured_main_args args; */
> +/*    args.argc = argc; */
> +/*    args.argv = argv; */
> +/*    catch_errors (captured_main, &args, "", RETURN_MASK_ALL); */
> +/*    return 0; */
> +/*  } */

I think you might was well remove main() entirely instead of
preserving it in a commented out form.  If there's a real need to
preserve it for a time, I think using #if 0 ...  #endif is preferable.

Kevin


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]