This is the mail archive of the gdb-patches@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

comment spelling corrections, approval requested




I am hereby requesting permission to commit the following
spelling corrections in comments.


2000-10-02  David B Anderson <davea@sgi.com>

        * TODO: Correct spelling errors
        * command.c (_initialize_command) corelow.c (core_open)  
        main.c (captured_command_loop) mips-tdep.c (mips32_next_pc)
        remote.c serial.h top.c utils.c config/nm-lynx.h:
        Correct spelling errors in comments




Index: TODO
===================================================================
RCS file: /cvs/src/src/gdb/TODO,v
retrieving revision 1.50
diff -u -p -r1.50 TODO
--- TODO	2000/09/06 15:23:04	1.50
+++ TODO	2000/10/02 21:33:19
@@ -71,7 +71,7 @@ Dan Nicolaescu writes:
 > stoping in weak functions. 
 > 
 > It stops in a function that is defined as weak, not in the function
-> that is actualy run... 
+> that is actually run... 
 
 --
 
@@ -314,7 +314,7 @@ determine the default isa/byte-order.
 
 --
 
-Rely on BFD_BIG_ENDIAN and BFD_LITTLE_ENDIAN instead of host dependant
+Rely on BFD_BIG_ENDIAN and BFD_LITTLE_ENDIAN instead of host dependent
 BIG_ENDIAN and LITTLE_ENDIAN.
 
 --
@@ -508,7 +508,7 @@ http://sourceware.cygnus.com/ml/gdb-patc
 Apart from the d30v, are there any sim/common simulators that make use
 of this?
 
-A brief summary of what happended is that sim/common/sim-break.c was
+A brief summary of what happened is that sim/common/sim-break.c was
 created as a good idea.  It turned out a better idea was to use
 SIM_SIGBREAK and have GDB pass back sim_resume (..., SIGBREAK).
 
@@ -604,7 +604,7 @@ Document overlay machinery.
 
 ``(gdb) catch signal SIGNAL''
 
-Overlaps with ``handle SIGNAL'' but the implied behavour is different.
+Overlaps with ``handle SIGNAL'' but the implied behavior is different.
 You can attach commands to a catch but not a handle.  A handle has a
 limited number of hardwired actions.
 
@@ -806,7 +806,7 @@ Rename read_register{,_pid}() to read_un
 
 If / when GDB starts to support the debugging of multi-processor
 (rather than multi-thread) applications the symtab code will need to
-be updated a little so that several independant symbol tables are
+be updated a little so that several independent symbol tables are
 active at a given time.
 
 The other interesting change is a clarification of the exact meaning
@@ -902,7 +902,7 @@ did have a frame pointer register.  Mode
 construct a virtual frame-handle from the stack pointer and various
 other bits of string.
 
-Unfortunatly GDB still treats this synthetic FP register as though it
+Unfortunately GDB still treats this synthetic FP register as though it
 is real.  That in turn really confuses users (arm and ``print $fp'' VS
 ``info registers fp'').  The synthetic FP should be separated out of
 the true register set presented to the user.
@@ -956,10 +956,10 @@ How I would like the register file to wo
              |
         map random cache
         bytes to target
-        dependant i-face
+        dependent i-face
             /|\
              |
-       target dependant
+       target dependent
         such as [gG] packet
         or ptrace buffer
 
@@ -990,7 +990,7 @@ The main objectives being:
 
         o       a mechanism that clearly separates the
                 gdb internal register cache from any
-                target (not architecture) dependant
+                target (not architecture) dependent
                 specifics such as [gG] packets.
 
 Of course, like anything, it sounds good in theory.  In reality, it
@@ -1075,7 +1075,7 @@ Fix target_signal_from_host() etc.
 
 The name is wrong for starters.  ``target_signal'' should probably be
 ``gdb_signal''.  ``from_host'' should be ``from_target_signal''.
-After that it needs to be multi-arched and made independant of any
+After that it needs to be multi-arched and made independent of any
 host signal numbering.
 
 --
@@ -1222,7 +1222,7 @@ The serial code already does this.
 
 --
 
-Make MI interface accessable from existing CLI.
+Make MI interface accessible from existing CLI.
 
 --
 
@@ -1337,7 +1337,7 @@ What should happen is that ``target xxxx
 open an asynchronous target that may need to perform background tasks
 as part of the ``attach'' phase.
 
-Unfortunatly, due to limitations in the old/creaking command.h
+Unfortunately, due to limitations in the old/creaking command.h
 interface, that isn't possible.  The function being called isn't told
 of the ``xxx'' or any other context information.
 
Index: command.c
===================================================================
RCS file: /cvs/src/src/gdb/command.c,v
retrieving revision 1.17
diff -u -p -r1.17 command.c
--- command.c	2000/08/08 00:17:39	1.17
+++ command.c	2000/10/02 21:33:20
@@ -2045,7 +2045,7 @@ _initialize_command (void)
 With no arguments, run an inferior shell.");
 
   /* NOTE: cagney/2000-03-20: Being able to enter ``(gdb) !ls'' would
-     be a really useful feature.  Unfortunatly, the below wont do
+     be a really useful feature.  Unfortunately, the below wont do
      this.  Instead it adds support for the form ``(gdb) ! ls''
      (i.e. the space is required).  If the ``!'' command below is
      added the complains about no ``!'' command would be replaced by
Index: corelow.c
===================================================================
RCS file: /cvs/src/src/gdb/corelow.c,v
retrieving revision 1.9
diff -u -p -r1.9 corelow.c
--- corelow.c	2000/09/01 23:41:20	1.9
+++ corelow.c	2000/10/02 21:33:20
@@ -329,7 +329,7 @@ core_open (char *filename, int from_tty)
   siggy = bfd_core_file_failing_signal (core_bfd);
   if (siggy > 0)
     /* NOTE: target_signal_from_host() converts a target signal value
-       into gdb's internal signal value.  Unfortunatly gdb's internal
+       into gdb's internal signal value.  Unfortunately gdb's internal
        value is called ``target_signal'' and this function got the
        name ..._from_host(). */
     printf_filtered ("Program terminated with signal %d, %s.\n", siggy,
Index: main.c
===================================================================
RCS file: /cvs/src/src/gdb/main.c,v
retrieving revision 1.3
diff -u -p -r1.3 main.c
--- main.c	2000/05/28 01:12:28	1.3
+++ main.c	2000/10/02 21:33:20
@@ -105,7 +105,7 @@ captured_command_loop (void *data)
   /* FIXME: cagney/1999-11-05: A correct command_loop() implementaton
      would clean things up (restoring the cleanup chain) to the state
      they were just prior to the call.  Technically, this means that
-     the do_cleanups() below is redundant.  Unfortunatly, many FUNC's
+     the do_cleanups() below is redundant.  Unfortunately, many FUNCs
      are not that well behaved.  do_cleanups should either be replaced
      with a do_cleanups call (to cover the problem) or an assertion
      check to detect bad FUNCs code. */
Index: mips-tdep.c
===================================================================
RCS file: /cvs/src/src/gdb/mips-tdep.c,v
retrieving revision 1.30
diff -u -p -r1.30 mips-tdep.c
--- mips-tdep.c	2000/08/19 05:32:23	1.30
+++ mips-tdep.c	2000/10/02 21:33:23
@@ -819,7 +819,7 @@ mips32_next_pc (CORE_ADDR pc)
 }				/* mips32_next_pc */
 
 /* Decoding the next place to set a breakpoint is irregular for the
-   mips 16 variant, but fortunatly, there fewer instructions. We have to cope
+   mips 16 variant, but fortunately, there fewer instructions. We have to cope
    ith extensions for 16 bit instructions and a pair of actual 32 bit instructions.
    We dont want to set a single step instruction on the extend instruction
    either.
Index: remote.c
===================================================================
RCS file: /cvs/src/src/gdb/remote.c,v
retrieving revision 1.23
diff -u -p -r1.23 remote.c
--- remote.c	2000/09/01 00:12:10	1.23
+++ remote.c	2000/10/02 21:33:25
@@ -2192,7 +2192,7 @@ serial device is attached to the remote 
 
   /* FIXME: cagney/1999-09-23: During the initial connection it is
      assumed that the target is already ready and able to respond to
-     requests. Unfortunatly remote_start_remote() eventually calls
+     requests. Unfortunately remote_start_remote() eventually calls
      wait_for_inferior() with no timeout.  wait_forever_enabled_p gets
      around this. Eventually a mechanism that allows
      wait_for_inferior() to expect/get timeouts will be
Index: serial.h
===================================================================
RCS file: /cvs/src/src/gdb/serial.h,v
retrieving revision 1.1.1.7
diff -u -p -r1.1.1.7 serial.h
--- serial.h	2000/02/02 00:21:10	1.1.1.7
+++ serial.h	2000/10/02 21:33:25
@@ -62,7 +62,7 @@ extern void serial_un_fdopen (serial_t s
 enum serial_rc {
   SERIAL_ERROR = -1,	/* General error. */
   SERIAL_TIMEOUT = -2,	/* Timeout or data-not-ready during read.
-			   Unfortunatly, through ui_loop_hook(), this
+			   Unfortunately, through ui_loop_hook(), this
 			   can also be a QUIT indication.  */
   SERIAL_EOF = -3	/* General end-of-file or remote target
 			   connection closed, indication.  Includes
Index: top.c
===================================================================
RCS file: /cvs/src/src/gdb/top.c,v
retrieving revision 1.17
diff -u -p -r1.17 top.c
--- top.c	2000/08/01 05:06:03	1.17
+++ top.c	2000/10/02 21:33:26
@@ -564,7 +564,7 @@ return_to_top_level (enum return_reason 
    code also randomly used a SET_TOP_LEVEL macro that directly
    initialize the longjmp buffers. */
 
-/* MAYBE: cagney/1999-11-05: Should the catch_erros and cleanups code
+/* MAYBE: cagney/1999-11-05: Should the catch_errors and cleanups code
    be consolidated into a single file instead of being distributed
    between utils.c and top.c? */
 
@@ -607,9 +607,9 @@ catch_errors (catch_errors_ftype *func, 
     val = (*func) (args);
   catch_return = saved_catch;
 
-  /* FIXME: cagney/1999-11-05: A correct FUNC implementaton will
+  /* FIXME: cagney/1999-11-05: A correct FUNC implementation will
      clean things up (restoring the cleanup chain) to the state they
-     were just prior to the call.  Unfortunatly, many FUNC's are not
+     were just prior to the call.  Unfortunately, many FUNC's are not
      that well behaved.  This could be fixed by adding either a
      do_cleanups call (to cover the problem) or an assertion check to
      detect bad FUNCs code. */
@@ -672,7 +672,7 @@ do_captured_command (void *data)
   /* FIXME: cagney/1999-11-07: Technically this do_cleanups() call
      isn't needed.  Instead an assertion check could be made that
      simply confirmed that the called function correctly cleaned up
-     after its self.  Unfortunatly, old code (prior to 1999-11-04) in
+     after itself.  Unfortunately, old code (prior to 1999-11-04) in
      main.c was calling SET_TOP_LEVEL(), calling the command function,
      and then *always* calling do_cleanups().  For the moment we
      remain ``bug compatible'' with that old code..  */
Index: utils.c
===================================================================
RCS file: /cvs/src/src/gdb/utils.c,v
retrieving revision 1.19
diff -u -p -r1.19 utils.c
--- utils.c	2000/07/30 01:48:27	1.19
+++ utils.c	2000/10/02 21:33:27
@@ -607,7 +607,7 @@ verror (const char *string, va_list args
   char *err_string;
   struct cleanup *err_string_cleanup;
   /* FIXME: cagney/1999-11-10: All error calls should come here.
-     Unfortunatly some code uses the sequence: error_begin(); print
+     Unfortunately some code uses the sequence: error_begin(); print
      error message; return_to_top_level.  That code should be
      flushed. */
   error_begin ();
Index: config/nm-lynx.h
===================================================================
RCS file: /cvs/src/src/gdb/config/nm-lynx.h,v
retrieving revision 1.2
diff -u -p -r1.2 nm-lynx.h
--- nm-lynx.h	2000/05/28 01:12:33	1.2
+++ nm-lynx.h	2000/10/02 21:33:27
@@ -73,7 +73,7 @@
 extern int child_wait (int pid, struct target_waitstatus *status);
 
 /* Lynx needs a special definition of this so that we can
-   print out the pid and thread number seperatly.  */
+   print out the pid and thread number seperately.  */
 
 
 /* override child_pid_to_str in inftarg.c */


Regards,
David B. Anderson davea@sgi.com danderson@acm.org http://reality.sgi.com/davea/

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]