This is the mail archive of the mailing list for the eCos project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE:Synthetic Serial-- Cannot get character output on serial port

I solved it-- it works with ttyS0 therefore:
synth_device serial {
	/dev/ser0 /dev/ttyS0
If I do the following:
echo "hello world" > /dev/ttyS0
cat /dev/ttyS0
It works both in and out.

ttyS0 is COM1 for pc.

SO works now... so far


>Hello, I am using eCos on linux ( using synthetic ).
>I have installed the synthetic serial port driver that works with auxiliary
>I/O program.  In my default.tdf file I have the following:
>synth_device serial {
>	/dev/ser0 /dev/tty1
>I am running the serial example that was installed with eCos.
>The /dev/ser0 is detected.
>But, upon the write to the device, I do not get anything at hyperterminal
>running on remote pc.
>stty -a -F /dev/tty1
>Shows that the port setup is ok-- baudrate, n81 The minicom program works
>fine with remote hyperterminal on tty1.
>I am currently at a loss.
>Can someone please give me some advice.

Before posting, please read the FAQ:
and search the list archive:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]