This is the mail archive of the binutils@sourceware.org mailing list for the binutils project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH v2] Rename __BIT() to N32_BIT() in the nds32 target


On 09/06/2017 04:10 PM, Kamil Rytarowski wrote:
> The __BIT() macro used by the nds32 code conflicts with the NetBSD
> header <sys/cdefs.h> with a different __BIT() implementation,
> althought used for the same purpose.
> 
> Remove the conflict with renaming __BIT() to N32_BIT().

This version's fine with me, thanks.  I can't approve this though,
since opcodes/ is maintained by the binutils folks.

(It'd be nice to get this in quickly, because this issue
is blocking the NetBSD GDB bot, FWIW.)

Thanks,
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]