This is the mail archive of the
mailing list for the binutils project.
Re: [AArch64][6/6] Core file support for "pauth" feature
On 17-08-10 22:32:40, Pedro Alves wrote:
> I think there's a misunderstanding. It's not about clarity -- if HWCAP_APIA
> is defined on a !Aarch64 host as some value other than "(1 << 16)", then
> > +++ b/gdb/aarch64-linux-tdep.c
> > - return tdesc_aarch64;
> > + return aarch64_hwcap & HWCAP_APIA ? tdesc_aarch64_pauth : tdesc_aarch64;
> > }
> will silently compile to use wrong value.
> Might never happen in practice, but why write a potential problem,
> _particularly since you already have to write the fallback
> macro anyway_? What's the advantage of not doing what I suggested?
I want the macro name sync'ed with kernel. However I understand your
point. Let me see if I can ask kernel people change it to HWCAP_ARM64_APIA,
or something else. Kernel patches are not merged yet, as far I as