This is the mail archive of the
mailing list for the binutils project.
Re: [PATCH 3/9] Rework RISC-V relocations
- From: Palmer Dabbelt <palmer at dabbelt dot com>
- To: vapier at gentoo dot org
- Cc: binutils at sourceware dot org
- Cc: Andrew Waterman <andrew at sifive dot com>
- Date: Sat, 17 Dec 2016 22:38:53 -0800 (PST)
- Subject: Re: [PATCH 3/9] Rework RISC-V relocations
- Authentication-results: sourceware.org; auth=none
On Fri, 16 Dec 2016 15:39:48 PST (-0800), firstname.lastname@example.org wrote:
> On 14 Dec 2016 20:23, Palmer Dabbelt wrote:
>> +riscv_pre_output_hook (void)
>> + frchainS *frchP;
> i don't think we normally use this naming style. if the "p" means
> pointer, then write it lower case instead of upper.
It looks like this code is mostly a copy of the xtensa code, but if it's odd
I'm OK just dropping the "P". I've done that in the v2.
>> + asection *s;
> should all of pointers in this func be const ? at a glance, seems like
> they should be.
I don't see why not (and GCC doesn't seem to either :)). Thanks for catching