This is the mail archive of the
mailing list for the binutils project.
Re: [PATCH v2 1/3] [ARC] Add NPS400 instruction subclass and flag
- From: Nick Clifton <nickc at redhat dot com>
- To: Graham Markall <graham dot markall at embecosm dot com>, binutils at sourceware dot org
- Cc: Claudiu dot Zissulescu at synopsys dot com
- Date: Mon, 20 Jun 2016 10:18:52 +0100
- Subject: Re: [PATCH v2 1/3] [ARC] Add NPS400 instruction subclass and flag
- Authentication-results: sourceware.org; auth=none
- References: <c3905738a7e5eaa75380b232d13711e042a7dbbc dot 1466085017 dot git dot graham dot markall at embecosm dot com> <1466174310-20047-1-git-send-email-graham dot markall at embecosm dot com>
Just to check - this is version2 of patch 1 of *4* not 1 of *3*, right ?
A couple of points:
* Please could you update gas/config/tc-arc.c:md_show_usage() to include
the new command line option. (Several other options are also missing
from that function. If you could include them, that would be swell).
* Please could you update gas/doc/c-arc.texi to include the new option.
> + if (!(arc_features & ARC_NPS400)
> + && is_nps400_p (sc))
> + return FALSE;
* I know that you are copying the other code fragments in this function,
but I find this test to completely backwards. Much better, IMHO, would
if (is_nps400_p (sc) && ! (arc_features & ARC_NPS400))
I see no need to break the tests up over two lines, and testing the subclass
before testing the feature enablement just makes more sense to me.
You do not have to make this change if you do not want to. But if you
agree with me and want to change the other tests in this function too, then
that would be appreciated.