binutils archive
subject index for April, 2015

This is the mail archive of the binutils@sourceware.org mailing list for the binutils project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Re: [AArch64/bfd/2.24] relocation truncated to fit: R_AARCH64_LD64_GOT_LO12_NC against

[AArch64] Improve PC-relative relocation check for shared library

Re: [AArch64] PR18270, fix handling of GOT entry for local symbol

[AArch64] PR18279, fix handling of GOT entry for local symbol

Re: [AArch64] Workaround for cortex-a53 erratum 843419

Re: [AArch64][2.25 Backport] Improve PC-relative relocation check for shared library

Re: [AArch64][Backport 2.25] PR18270, fix handling of GOT entry for local symbol

[AArch64][gas][2.25] Backport support for Samsung Exynos M1

[ARM][gas][2.25] Backport support for Samsung Exynos M1

[comitted, PATCH] Add SHF_COMPRESSED support to readelf

[comitted, PATCH] PR binutils/18316: SEC_MEP_VLIW is defined in include/elf/mep.h

[commited, PATCH] Add a dw2-3.S test

[committed, PATCH] Add Elf_Internal_Chdr and ElfXX_External_Chdr

[committed, PATCH] Also preserve the SHF_COMPRESSED bit

[committed, PATCH] Always set up sh_name in assign_section_numbers

[committed, PATCH] Check dp->prefix_requirement instead

[committed, PATCH] Check GOTOFF reloc against protected data on x86

[committed, PATCH] Copy is_linker_input to archive member

[committed, PATCH] Don't hardcode offset of .shstrtab section

Re: [committed, PATCH] Don't write the zlib header if not used

[committed, PATCH] Extract get_uncompressed_size

Re: [committed, PATCH] Fix sim build

[committed, PATCH] Initialize pagesize_m1 in bfd_cache_init

[committed, PATCH] Iterate ELF sections by pointer

[committed, PATCH] Link the last *normal against libfoozlib.so

[committed, PATCH] Mention --compress-debug-sections=

[committed, PATCH] PR binutils/17898: rdrand/rdseed should not disassmble with f2/f3 prefixes present

[committed, PATCH] PR ld/18289: Support copy relocation in PIE

[committed, PATCH] Remove "/dev/null" from remote_exec

[committed, PATCH] Remove is_zlib_supported

[committed, PATCH] Remove the unused PREFIX_UD_XXX

[committed, PATCH] Replace mandatory_prefix with prefix_requirement

[committed, PATCH] Replace SYMBOLIC_BIND with SYMBOL_REFERENCES_LOCAL

[committed, PATCH] Silence texinfo 5.1 warnings

[committed, PATCH] Undef elf_backend_post_process_headers for Solaris

[committed, PATCH] Update comments in compress.c

[committed, PATCH] Use "else if" on cpu_arch_isa

[committed, PATCH]: Make is_zlib_supported always return 1

[committed] ob: merge include/partition.h from gcc

[Committed] S/390: z13 instruction type fixes

[comnitted, PATCH] Display --interleave[=<number>]

[gas] new port advice

[GAS][AARCH64]Don't try to align insn in non-executale section.

[GAS][AARCH64]use subseg_text_p to check whether current segment is thought to hold text.

[GAS][ARM]Positively emit symbols for alignment.

Re: [GAS][ARM]Positively emit symbols for alignment. --> [PATCH][LD][ARM] Fix two test case failures.

[gold commit] Allow gold to resolve defined TLS symbols in a PIE link

[gold commit] Improve ODR checking in gold

Re: [gold] [PATCH] Add --with-system-zlib in gold

[gold][aarch64] Patch for erratum-843419 (1 of 2 - report erratum occurrences)

[gold][aarch64]: Rename '--fix-cortex-a53' to '--fix-cortex-a53-843419'

[gold][PATCH] Add chdr_size, Chdr, Chdr_write and Chdr_data

[gold][PATCH] Add SHF_COMPRESSED and ELFCOMPRESS_XXX to elfcpp.h

[gold][PATCH] Add SHF_COMPRESSED section decompression to gold

[gold][PATCH] Extend --compress-debug-sections in gold

[gold][PATCH] PR gold/18321: gold doesn't support SHF_COMPRESSED sections

[gold][PATCH] PR gold/18322: gold doesn't support --compress-debug-sections={zlib-gabi|zlib-gnu}

[MIPS][bfd] Merging mips .reginfo sections

[PATCH 0/4] xtensa ld relaxation performance optimizations

[PATCH 1/4] xtensa: optimize check_section_ebb_pcrels_fit

[PATCH 2/4] xtensa: optimize removed_by_actions

[PATCH 3/4] xtensa: optimize find_removed_literal

[PATCH 4/4] xtensa: replace action list with splay tree

Re: [PATCH v2] Add support for the x86 XSAVE extended state on FreeBSD/x86.

Re: [PATCH v2] ld/emulparams/elf32_tic6x_le.sh: Skip OTHER_BSS_SECTIONS for relocating operation.

[PATCH v2] Put GNU_UNIQUE symbols into the dynamic section.

[PATCH v2][RX] Add RXv2 Instructions (1/3)

[PATCH v2][RX] Add RXv2 Instructions (2/3)

[PATCH v2][RX] Add RXv2 Instructions (3/3)

[Patch, avr] PR 18269 Fix build warning

[PATCH, committed] Fix r6-branch-constraints test

[PATCH, MIPS] Improve warning messages for la/dla

Re: [PATCH] [AArch64] Add support for the Samsung Exynos M1 processor

Re: [PATCH] [ARM] Add support for the Samsung Exynos M1 processor

[PATCH] A few ppc assembler fixes

[PATCH] Add FreeBSD aarch64 support

[PATCH] Add ld_list_options

[PATCH] Add SHF_COMPRESSED support to gas and objcopy

Re: [PATCH] Add support for the target mips64*-*-linux-gnuabi64

[PATCH] allow gold subdir building for mips

[PATCH] binutils: update my e-mail address

[patch] Don't copy a set

[PATCH] Eat newlines in INPUT statements

Re: [PATCH] Fixes for a small number of compiler warnings

RE: [Patch] Gas support for MIPS Compact EH

[patch] Ignore non relobj files in gc

[patch] Ignore relocations from .eh_frame for gc

[PATCH] PR binutils/18218: bad handling of .debug_str_offsets section

Re: [PATCH] PR gold/17640

[PATCH] PR gold/17641

[PATCH] PR ld/18250: segfault on BFD linker using clang llvm plugin

[PATCH] PR ld/18329: Turn off PROTECTED visibility with -Bsymbolic

[PATCH] PR ld/18355: --enable-shared doesn't work

[PATCH] Put GNU_UNIQUE symbols into the dynamic section.

[PATCH] readline: rlmbutil.h: Declare wcwidth() when HANDLE_MULTIBYTE enabled.

[PATCH] readline: rltty.c: Declare ioctl() explicitly.

[PATCH] Regenerate configure in gold

[PATCH] Remove unused set_error_{kind,message}

[PATCH] S/390: Add support for GNU attribute vector ABI tag

[PATCH] S/390: Fix gotpcrel testcase

[patch] Use a std::vector instead of a std::map to hold Input_merge_map

[PATCH] Use bfd_alloc for compressed section contents

[PATCH] use gold/configure.tgt to calc supported targets

[patch] Use insert's return value instead of find + insert

[PATCH] Use per instruction prefix control.

[patch] Use unaligned access on x86_64

[PATCH] x86/Intel: accept mandated operand order for vcvt{,u}si2s{d,s}

[PATCH] x86/Intel: disassemble vcvt{,u}si2s{d,s} with correct operand order

[PATCH] x86: disambiguate disassembly of certain AVX512 insns

[PATCH] x86: don't require operand size specification for AVX512 broadcasts

Re: [PATCH][GAS][AARCH64]Emit DATA_MAP in order within text section, align code when transformed from MAP_DATA state into MAP_INSN state.

[PATCH][GAS][AARCH64]Record instruction alignment for .inst directive.

[patch][gold] Fix pr18327

[patch][gold] Use LIFO instead of FIFO to implement gc's transitive closure

[PATCH][OPCODES][ARM]Disassembles SSAT and SSAT16 instructions immediate field incorrectly for Thumb-2

[RFC] Backport of workaround for cortex-a53 erratum 843419 to 2.24

Re: [RFC][ARM][AARCH64] Set DWARF2_LINE_MIN_INSN_LENGTH to 1

Accept odd result in ld-powerpc/tocnovar testcase

Adding new section to core file

Align .TOC. for PowerPC64

ARM: Don't tail-pad over-aligned sections

Cast shift expression

Change of address

Commit: _bfd_is_local_label_name: Include assembler local labels

Commit: AArch64: Fix failure of binutils/readelf.ss test

Commit: Add --warn-orphan option to the linker

Commit: GAS: Update .set description

Commit: Microblaze: sign extend immediates before checking

Commit: RL78: Generate complex relocs for DWARF sections

Commit: RX: Add support for detecting string insn use

Commit: Skip compressed1d test for ELF targets that do not use elf.em

Downgrade linker error on protected symbols in .dynbss to a warning

ELF options may be missing from `ld --help' output after migration to ld_list_options

Enable 0x10 alignment for aarch64 symbols as is done for x86_64

Fix ld eelf32ppcvxworks.c dependencies

Fix virtual method signature

galleon leisure centre

Gas bug: Broken code generated for inter-section arithmetic.

gas thunderx support

Git email hook stopped working after bugzilla update

Re: ld for ia64-hp-openvms target

Mark _init and _fini for --gc-sections

MEMORY attributes in linker script

Modify get_reloc_section for targets that map .got.plt to .got

msp430 -> msp430elf emulation

New Danish PO file for 'gprof' (version 2.24.90)

New Finnish PO file for 'gold' (version 2.24.90)

New French PO file for 'ld' (version 2.24.90)

New French PO file for 'opcodes' (version 2.24.90)

page align

Patch to not create GOT and dynamic relocation entries for unresolved symbols with --warn-unresolved-symbols.

PATCH: Add --compress-debug-sections=[none|zlib|zlib-gnu|zlib-gabi] to ld

PATCH: PR binutils/18209: objdump -h is not very helpful printing decompressed section names

PATCH: PR ld/18277: --compress-debug-sections=zlib may generate larger debug sections

PATCH: Update --with-system-zlib

PowerPC gold assertion on missing global entry stub

PowerPC non-PIC to PIC editing for protected var access

Regression with your binutils 3e19fb8

Rewrite relro adjusting code

RFC: Add --compress-debug-sections=[none|zlib|zlib-gnu|zlib-gabi] to ld

RFC: PR ld/18277: --compress-debug-sections=zlib may generate larger debug sections

Re: Some extensions to the .section directive for ELF and COFF

Start of relro segment adjustment

use-after-free defensive technique !

we can bring you buying leads

Why is gold still beta?

xfail pr18223 test for tic6x


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc