This is the mail archive of the binutils@sourceware.org mailing list for the binutils project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[MIPS][committed] Rename COPROC related macros


A mechanical patch to remove the word 'DELAY' from two attributes in
the MIPS opcode tables. This has been changed as the attributes are now
applied to micromips instructions (as required by the code which handles
-mno-odd-spreg). The micromips instructions will never need NOPs inserting
as they have always interlocked correctly so the 'delay' is meaningless
and confusing for the new uses. There is no functional change in this
patch.

Tested with mips64-linux-gnu and applied.

Thanks,
Matthew

gas/

	* config/tc-mips.c: Rename INSN_LOAD_COPROC_DELAY to INSN_LOAD_COPROC
	and INSN_COPROC_MOVE_DELAY to INSN_COPROC_MOVE throughout.

include/opcode/

	* mips.h (INSN_LOAD_COPROC_DELAY): Rename to...
	(INSN_LOAD_COPROC): New define.
	(INSN_COPROC_MOVE_DELAY): Rename to...
	(INSN_COPROC_MOVE): New define.

opcodes/

	* micromips-opc.c (COD): Rename throughout to...
	(CM): New define, update to use INSN_COPROC_MOVE.
	(LCD): Rename throughout to...
	(LC): New define, update to use INSN_LOAD_COPROC.
	* mips-opc.c: Likewise

Attachment: 0001-MIPS-Rename-COPROC-related-macros.patch
Description: 0001-MIPS-Rename-COPROC-related-macros.patch


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]