This is the mail archive of the binutils@sourceware.org mailing list for the binutils project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] MIPS EVA ASE Support


"Maciej W. Rozycki" <macro@codesourcery.com> writes:
>> 	{
>> -	  /* A 12-bit or 0-bit offset field is too narrow to be used
>> -	     for a low-part relocation, so load the whole address into
>> -	     the auxillary register.  In the case of "A(b)" addresses,
>> +	  /* A 12-bit, 0-bit or 9-bit offset field is too narrow to be
>
>  Suggest sorting the bit count, i.e.:
>
> 	  /* A 12-bit, 9-bit or 0-bit offset field is too narrow to be

Bikeshed stuff, but I'd prefer "The offset field is too narrow..."
and drop the list altogether.

>  I'll let Richard comment on the rest.

My only other comment is: rather than

      if (mips_opts.micromips)
	offbits = 12;

please use:

      offbits = (mips_opts.micromips ? 12 : 16);

(several instances).

Thanks,
Richard


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]