This is the mail archive of the binutils-cvs@sourceware.org mailing list for the binutils project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

gdb and binutils branch master updated. 5575639b8dbb2a04087c3bef0b10f182da48ad35


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, master has been updated
       via  5575639b8dbb2a04087c3bef0b10f182da48ad35 (commit)
      from  0db377d09c19fc0f9267ead1f75998b9f1eb38d1 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=5575639b8dbb2a04087c3bef0b10f182da48ad35

commit 5575639b8dbb2a04087c3bef0b10f182da48ad35
Author: Maciej W. Rozycki <macro@codesourcery.com>
Date:   Tue Aug 26 13:44:34 2014 +0100

    MIPS: Make the CODE10 operand code consistent between ISAs
    
    This change moves the microMIPS 10-bit uninterpreted immediate code
    embedded at bits 25..16 in the SYSCALL, WAIT, SDBBP and HYPCALL
    instructions from `B' over to `+J' which is the operand code used in
    the standard MIPS instruction set for a similar code embedded at bits
    20..11, currently used by HYPCALL only in that set.
    
    	opcodes/
    	* micromips-opc.c (decode_micromips_operand): Rename `B' to `+J'.
    	(micromips_opcodes): Use "+J" in place of "B" for "hypcall",
    	"sdbbp", "syscall" and "wait".
    
    	include/opcode/
    	* mips.h: Document the move of `MICROMIPSOP_*_CODE10' from `B'
    	over to `+J'.

-----------------------------------------------------------------------

Summary of changes:
 include/opcode/ChangeLog |    5 +++++
 include/opcode/mips.h    |    7 ++++---
 opcodes/ChangeLog        |    6 ++++++
 opcodes/micromips-opc.c  |   10 +++++-----
 4 files changed, 20 insertions(+), 8 deletions(-)


hooks/post-receive
-- 
gdb and binutils


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]