This is the mail archive of the mailing list for the Archer project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: gdb side of improved linker-debugger interface

Jan Kratochvil wrote:
> On Tue, 07 Jun 2011 11:48:08 +0200, Gary Benson wrote:
> > I've seen mention that the RT_CONSISTENT called too early bug was
> > the cause of another issue where libthread_db would not be loaded
> > if libpthread was loaded with dlopen rather than being linked in,
> > but I haven't been able to discover if this really was ever the
> > case.  If anybody knows (or has a testcase) could you fill me in
> > on it please.
> the testcase from:
> works for me - that is it does not work.  I haven't tried it with
> your glibc+gdb, I guess it works now?

It actually doesn't fail on standard F14 gdb:

  $ gdb ./testload
  GNU gdb (GDB) Fedora (7.2-51.fc14)
  Copyright (C) 2010 Free Software Foundation, Inc.
  License GPLv3+: GNU GPL version 3 or later <>
  This is free software: you are free to change and redistribute it.
  There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
  and "show warranty" for details.
  This GDB was configured as "x86_64-redhat-linux-gnu".
  For bug reporting instructions, please see:
  Reading symbols from /home/gary/work/archer/rh179072-tests/testload...done.
  (gdb) r
  Starting program: /home/gary/work/archer/rh179072-tests/testload 
  [Thread debugging using libthread_db enabled]
  [New Thread 0x7ffff7dd5700 (LWP 5584)]
  [Thread 0x7ffff7dd5700 (LWP 5584) exited]
  Program exited normally.

Not sure what's happening there...



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]