This is the mail archive of the
mailing list for the Archer project.
Re: [python][rfc] rename Frame.read_var_value to Frame.read_var
El mar, 03-03-2009 a las 09:26 -0700, Tom Tromey escribiÃ:
> >>>>> "Thiago" == Thiago Jung Bauermann <firstname.lastname@example.org> writes:
> Thiago> I think the method read_var_value in gdb.Frame should be renamed to the
> Thiago> shorter name read_var. This patch makes the change. WDYT?
> It is fine by me; I agree that "_value" is redundant.
> Did you consider the unabbreviated "read_variable"?
No, do you think it's better? I slightly prefer the shorter version as
it save some keystrokes and "var" is easy to recognize, but I wouldn't
mind using the unabberviated name.
Thiago Jung Bauermann
IBM Linux Technology Center