This is the mail archive of the
mailing list for the Archer project.
Re: [python][rfc] Rename gdb.current_frame to gdb.newest_frame.
- From: Tom Tromey <tromey at redhat dot com>
- To: Thiago Jung Bauermann <bauerman at br dot ibm dot com>
- Cc: archer ml <archer at sourceware dot org>
- Date: Mon, 05 Jan 2009 16:34:44 -0700
- Subject: Re: [python][rfc] Rename gdb.current_frame to gdb.newest_frame.
- References: <firstname.lastname@example.org><email@example.com>
- Reply-to: Tom Tromey <tromey at redhat dot com>
>>>>> "Thiago" == Thiago Jung Bauermann <firstname.lastname@example.org> writes:
Thiago> El mar, 16-12-2008 a las 20:20 -0200, Thiago Jung Bauermann escribiÃ:
>> I'm documenting gdb.Frame. In the process, I realized that
>> gdb.current_frame is not a good name for what it really provides. I
>> decided to call it gdb.newest_frame, to maintain consistency with the
>> gdb.Frame.older and gdb.Frame.newer methods. What do you think?
Thiago> I just committed this. I figured silence means people agree or don't
Thiago> care. :-) It's easy enough to change if someone disagrees.
Yeah -- be bold.
Sorry for not responding to that note. I miss things sometimes. You
can always ping me if you really want a response :)
>> Also, it seems to me that caller_is and caller_matches should call
>> gdb.selected_frame instead of gdb.newest_frame, but I'm not really sure.
>> This patch makes the change. What do you think?
Thiago> But I kept caller_is and caller_matches using gdb.newest_frame, since I
Thiago> don't use these functions so I am not sure of what is expected by their
Hah, me neither. But I think using the selected frame is perhaps better.
My use for this function is on a breakpoint condition, where the
distinction doesn't matter. But one could imagine using it in
"commands", after an "up-silent" or something...