This is the mail archive of the
mailing list for the Archer project.
Re: [python][rfc] Rename gdb.current_frame to gdb.newest_frame.
- From: Thiago Jung Bauermann <bauerman at br dot ibm dot com>
- To: archer ml <archer at sourceware dot org>
- Date: Mon, 29 Dec 2008 17:28:32 -0200
- Subject: Re: [python][rfc] Rename gdb.current_frame to gdb.newest_frame.
- References: <firstname.lastname@example.org>
El mar, 16-12-2008 a las 20:20 -0200, Thiago Jung Bauermann escribiÃ:
> I'm documenting gdb.Frame. In the process, I realized that
> gdb.current_frame is not a good name for what it really provides. I
> decided to call it gdb.newest_frame, to maintain consistency with the
> gdb.Frame.older and gdb.Frame.newer methods. What do you think?
I just committed this. I figured silence means people agree or don't
care. :-) It's easy enough to change if someone disagrees.
> Also, it seems to me that caller_is and caller_matches should call
> gdb.selected_frame instead of gdb.newest_frame, but I'm not really sure.
> This patch makes the change. What do you think?
But I kept caller_is and caller_matches using gdb.newest_frame, since I
don't use these functions so I am not sure of what is expected by their
Thiago Jung Bauermann
IBM Linux Technology Center