This is the mail archive of the
mailing list for the Archer project.
Re: [python][rfc] Rename gdb.Frame getters.
El vie, 05-12-2008 a las 16:24 -0700, Tom Tromey escribiÃ:
> >>>>> "Thiago" == Thiago Jung Bauermann <firstname.lastname@example.org> writes:
> Thiago> (frapy_get_next): Rename to ...
> Thiago> (frapy_next): ... this.
> The problem here is that "next" is the name used by iterators.
> I'd rather we not clash with that.
A frame is not an iterator, so I don't see a clash unless we want to
turn it into an iterator at some point. Is that what you worry about?
> Maybe "next_frame" and "previous_frame"?
> Or even "newer_frame" and "older_frame"?
> Or ... any suggestions?
What about "newer" and "older"? Or perhaps just keeping "get_next" and
"get_prev" (though the former has a clearer meaning). In any case, the
"_frame" suffix is redundant.
Thiago Jung Bauermann
IBM Linux Technology Center