Bug 6514

Summary: Stepping engine is broken
Product: frysk Reporter: Martin Hunt <hunt>
Component: generalAssignee: Unassigned <frysk-bugzilla>
Status: RESOLVED DUPLICATE    
Severity: critical    
Priority: P1    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on: 6572, 6574    
Bug Blocks:    

Description Martin Hunt 2008-05-13 16:15:41 UTC
> fhpd p
[0.0] Loaded executable file: /home/hunt/test/p
(fhpd) b main
breakpoint 0 deferred
(fhpd) r
running with this commmand:  /home/hunt/test/p
Attached to process 8605
Running process 8605
(fhpd) Breakpoint 0 main 0x400557
list
[0.0]
     1   #include<stdio.h>
     2   #include<string.h>
     3   
     4   int main(int argc, char *argv[])
     5   {
->   6     char *twofifty = "250";
     7     int j250;
     8     int i250 = atoi(twofifty);
     9     
    10     if ((j250 = atoi(twofifty)) != i250)
    11       {
    12         printf("fubar!\n");
    13         return (1);
    14       }
    15     printf("%s = %d = %d\n", twofifty, i250, j250);
    16     return(0);
    17   }
(fhpd) n
Task stopped at line 8 in file /home/hunt/test/p.c
(fhpd) n
Task stopped at line 8 in file /home/hunt/test/p.c
(fhpd) n
Task stopped at line 10 in file /home/hunt/test/p.c
(fhpd) n
Task stopped at line 10 in file /home/hunt/test/p.c
(fhpd) n
Task stopped at line 10 in file /home/hunt/test/p.c
(fhpd) n
Task stopped at line 15 in file /home/hunt/test/p.c
(fhpd) n
250 = 250 = 250
Task stopped at line 16 in file /home/hunt/test/p.c

-----
Rerun and use "s" step into gives different (also wrong) results

(fhpd) Breakpoint 0 main 0x400557

(fhpd) s
Task stopped at line 8 in file /home/hunt/test/p.c
(fhpd) s
Task stopped at line 8 in file /home/hunt/test/p.c
(fhpd) s
Task stopped at line 10 in file /home/hunt/test/p.c
(fhpd) s
Task stopped at line 10 in file /home/hunt/test/p.c
(fhpd) s
Task stopped at line 15 in file /home/hunt/test/p.c
(fhpd) s
250 = 250 = 250
Task stopped at line 16 in file /home/hunt/test/p.c
Comment 1 Andrew Cagney 2008-05-27 16:35:29 UTC
Duping to stepping engine tracker; the two problems identified by the bug:
- step over multiple functions
- step not clear when mid-instruction
have been filed separatly

*** This bug has been marked as a duplicate of 3346 ***