This is the mail archive of the mailing list for the systemtap project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug runtime/17986] unprivileged_myproc.exp and unprivileged_probes.exp regressed on el6 (systemtap-2.5-5.el6 versus release-2.6-274-gbabad5b31b70)

--- Comment #4 from David Smith <dsmith at redhat dot com> ---
(In reply to Jonathan Lebon from comment #3)
> As per bug 17906, .nearest probes are now accepted for both wildcarded and
> enumerated line number types. The remaining failures in
> unprivileged_probes.exp seem to all be from the same error relating to
> process(number) probes, e.g.:
> eval exec stap -p2 --privilege=stapsys -e {probe
> process(10).statement(0x00000000004007f0) { println ("Hello"); exit (); }}
> -c ./foo
> semantic error: while resolving probe point: identifier 'process' at
> <input>:1:7
>         source: probe process(10).statement(0x00000000004007f0) { println
> ("Hello"); exit (); }
>                       ^
> semantic error: no match
> Pass 2: analysis failed.  [man error::pass2]
> FAIL: unprivileged probes: --privilege=stapsys
> process(number).statement(number)

On the f21 (3.18.9-200.fc21.x86_64) system where I ran the tests, process 10 is
a kernel thread. I'll try to modify the test so that we point to a real process
and see if that fixes things.

You are receiving this mail because:
You are the assignee for the bug.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]