libc-alpha archive
subject index for March, 2018

This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

[2.27 COMMITTED 1/3] RISC-V: Do not initialize $gp in TLS macros.

[2.27 COMMITTED 2/3] RISC-V: fmax/fmin: Handle signalling NaNs correctly.

[2.27 COMMITTED 3/3] Update ChangeLog for BZ 22884 - riscv fmax/fmin

Re: [bz 22342] patch V2: fix netgroup cache keys

[bz 22342] patch: fix netgroup cache keys

[commited] Add missing start-of-file descriptive comment.

[commited] hurd: Fix includability of <hurd/signal.h> in all standards

[commited] x86_64: Fix build with RTLD_PRIVATE_ERRNO defined to 1

[COMMITTED 1/3] benchtests: Convert strncmp benchmark output to json

[COMMITTED 2/3] benchtests: Reallocate buffers for every strncmp implementation

[COMMITTED 3/3] benchtests: Don't benchmark 0 length calls for strncmp

[COMMITTED] sparc: Fix arch_fork definition

[hurd,commited 0/2] hurd: Fix *utime* support

[hurd,commited 0/5] hurd patches

[hurd,commited 1/2] hurd: Define and pass UTIME_NOW and UTIME_OMIT to new file_utimens RPC

[hurd,commited 1/5] hurd: Fix O_NOFOLLOW

[hurd,commited 2/2] hurd: Add futimesat and utimensat support

[hurd,commited 2/5] hurd: Fix O_DIRECTORY | O_NOFOLLOW

[hurd,commited 3/5] hurd: Fix boot with statically-linked exec server

[hurd,commited 4/5] hurd: Add mlockall support

[hurd,commited 5/5] Hurd: fix port leak in TLS

[hurd,commited] Fix errno values

[hurd,commited] hurd: Add futimens support

[hurd,commited] hurd: add gscope support

[hurd,commited] hurd: Add missing include

[hurd,commited] hurd: Add missing includes

[hurd,commited] hurd: add TLS support

[hurd,commited] hurd: advertise process memory locking option

[hurd,commited] hurd: avoid including hurd/signal.h when not needed

[hurd,commited] hurd: avoid letting signals go to thread created by timer_create

[hurd,commited] hurd: Avoid using ino64_t and loff_t in headers

[hurd,commited] hurd: Code style fixes

[hurd,commited] hurd: do not check Mach and Hurd headers

[hurd,commited] hurd: Fix accessing errno from rtld

[hurd,commited] hurd: fix build

[hurd,commited] hurd: Fix build with latest htl

[hurd,commited] hurd: Fix calling __pthread_initialize_minimal in shared case

[hurd,commited] hurd: Fix coding style

[hurd,commited] hurd: Fix copyright years

[hurd,commited] hurd: Fix getting signal thread stack layout for fork

[hurd,commited] hurd: fix header conformity

[hurd,commited] hurd: Fix inclusion of mach headers in all standards

[hurd,commited] hurd: Fix link cthread/pthread symbol exposition.

[hurd,commited] hurd: Initialize TLS and libpthread before signal thread start

[hurd,commited] hurd: Make almost all hurd headers includable in all standards

[hurd,commited] hurd: Move mach/param.h to bits/mach/param.h

[hurd,commited] hurd: Reimplement libc locks using mach's gsync

[hurd,commited] hurd: Replace threadvars with TLS

[hurd,commited] hurd: Rewrite __libc_cleanup_*

[hurd,commited] Lookup the startup server through /servers/startup

[hurd,commited] Separate out error_t definition

[PATCH 0/1] cs_CZ: Add alternative month names (bug 22963).

[PATCH 0/2] Abbreviated month name updates for lt_LT and el_* [BZ 22932,22937]

Re: [PATCH 0/2] nptl: Update struct pthread_unwind_buf

[PATCH 0/9] Use more flags parameters instead of global bits in stdio

[PATCH 1/1] cs_CZ: Add alternative month names (bug 22963).

[PATCH 1/2] lt_LT locale: Update abbreviated month names (bug 22932).

Re: [PATCH 1/3] Refactor Linux ARCH_FORK implementation

[PATCH 1/3] Tunables: Add tunables of spin count for adaptive spin mutex

[PATCH 1/6] Remove slow paths from sin/cos

[PATCH 1/7] Assume O_DIRECTORY for opendir

[PATCH 1/7] sin/cos slow paths: avoid slow paths for small inputs

[PATCH 1/9] Use STRFMON_LDBL_IS_DBL instead of __ldbl_is_dbl.

[PATCH 2/2] Greek (el_CY, el_GR) locales: Introduce ab_alt_mon (bug 22937).

[PATCH 2/3] Mutex: Only read while spinning

[PATCH 2/6] Remove slow paths from sin/cos

[PATCH 2/7] Define _DIRENT_MATCHES_DIRENT64 regardless

[PATCH 2/7] sin/cos slow paths: remove large range reduction

[PATCH 2/9] Add __vfscanf_internal and __vfwscanf_internal with flags arguments.

[PATCH 3/3] Mutex: Avoid useless spinning

[PATCH 3/6] Remove slow paths from sin/cos

[PATCH 3/7] Consolidate Linux readdir{64}{_r} implementation

[PATCH 3/7] sin/cos slow paths: remove slow paths from small range reduction

[PATCH 3/9] Use SCANF_ISOC99_A instead of _IO_FLAGS2_SCANF_STD.

[PATCH 4/6] Remove slow paths from sin/cos

[PATCH 4/7] Consolidate Linux getdents{64} implementation

[PATCH 4/7] sin/cos slow paths: remove slow paths from huge range reduction

[PATCH 4/9] Use SCANF_LDBL_IS_DBL instead of __ldbl_is_dbl.

[PATCH 5/6] Remove slow paths from sin/cos

[PATCH 5/7] Consolidate scandir{at}{64} implementation

[PATCH 5/7] sin/cos slow paths: remove unused slowpath functions

[PATCH 5/9] Add __v*printf_internal with flags arguments.

[PATCH 6/6] Remove slow paths from sin/cos

[PATCH 6/7] Consolidate alphasort{64} and versionsort{64} implementation

[PATCH 6/7] sin/cos slow paths: refactor duplicated code into dosin

[PATCH 6/9] Add __vsyslog_internal, with same flags as __v*printf_internal.

[PATCH 7/7] Consolidate getdirentries{64} implementation

[PATCH 7/7] sin/cos slow paths: refactor sincos implementation

[PATCH 7/9] Use PRINTF_FORTIFY instead of _IO_FLAGS2_FORTIFY.

[PATCH 8/9] Use PRINTF_LDBL_IS_DBL instead of __ldbl_is_dbl.

[PATCH 9/9] Post-cleanup: don't include math.h/math_private.h in math_ldbl_opt.h.

[PATCH COMMITTED] NEWS: Mention the locale data changes (bug 22848, 22937, 22963).

[PATCH COMMITTED] nptl: Drop libpthread_nonshared.a from libpthread.so

[PATCH COMMITTED] Update translations from the Translation Project

Re: [PATCH v2 1/2] elf: Unify symbol address run-time calculation [BZ #19818]

Re: [PATCH v2 2/2] elf: Correct absolute (SHN_ABS) symbol run-time calculation [BZ #19818]

Re: [PATCH v2] [BZ 1190] Make EOF sticky in stdio.

Re: [PATCH v2] Add malloc micro benchmark

[PATCH v2][BZ 22848] ca_ES locale: Update LC_TIME for Catalan

[PATCH v3 1/3] Cleanup __ieee754_sqrt(f/l)

[PATCH v3 2/3] Cleanup __ieee754_sqrt(f/l)

[PATCH v3 3/3] Cleanup __ieee754_sqrt(f/l)

[PATCH v3] powerpc64*: fix the order of implied sysdeps directories

[PATCH v4 1/3] Cleanup __ieee754_sqrt(f/l)

Re: [Patch v4 13/14] [BZ #14095] update collation data from Unicode / ISO 14651

[PATCH v4 2/3] Cleanup __ieee754_sqrt(f/l)

[PATCH v4 3/3] Cleanup __ieee754_sqrt(f/l)

[PATCH v4] powerpc64*: fix the order of implied sysdeps directories

[PATCH] aarch64: Improve strncmp for mutually misaligned inputs

Re: [PATCH] aarch64: Optimized memcmp for medium to large sizes

[PATCH] Add $(tests-execstack-$(have-z-execstack)) after defined [BZ #22998]

[PATCH] Add include guards to bits/sigaction.h

[PATCH] alpha/clone.S: Invoke .set noat/.set at around explicit uses of $at

[PATCH] alpha: Add cfi information for _startcontext routines to stop unwinding [BZ#22910]

[PATCH] Don't include math.h/math_private.h in math_ldbl_opt.h.

[PATCH] elf: Add AES-128 implementation for arc4random

[PATCH] Fix crash in resolver on memory allocation failure (bug 23005)

Re: [PATCH] Fix i386 memmove issue [BZ #22644]

[PATCH] Fix multiple definitions of __nss_*_database (bug 22918)

[PATCH] getlogin_r: return early when linux sentinel value is set

[PATCH] getpt: use /dev/pts/ptmx as default ptmx master

[PATCH] hurd: add gscope support

Re: [PATCH] hurd: Define and pass UTIME_NOW and UTIME_OMIT to new file_utimens RPC

[PATCH] hurd: Do not completely ignore Mach headers checks

[PATCH] hurd: Fix early rtld access to errno

[PATCH] hurd: Initialize TLS and libpthread before signal thread start

[PATCH] Improves __ieee754_exp(x) performance by 18-37% when |x| < 1.0397

Re: [PATCH] malloc: harden removal from unsorted list

[PATCH] malloc: Revert sense of prev_inuse in comments

[PATCH] nldbl-compat.c: Include math.h before nldbl-compat.h.

[PATCH] nptl: Add pthread_thread_number_np function

Re: [PATCH] nptl: Fix tst-cancel4 sendto tests

Re: [PATCH] nptl: Move pthread_atfork to libc_nonshared.a

Re: [PATCH] nptl_db: Remove stale `match_pid' parameter from `iterate_thread_list'

[PATCH] powerpc: Expose VSX feature test

[PATCH] powerpc: Fix TLE build for SPE (BZ #22926)

[PATCH] powerpc: Fix tst-set_ppr.c on 32-bit POWER7

Re: [PATCH] Remove hidden __libc_longjmp

[PATCH] Replace strncpy with memccpy to fix -Wstringop-truncation.

[PATCH] RISC-V: add remaining relocations

[PATCH] Separate out error_t definition

[PATCH] sparc32: Add nop before __startcontext to stop unwinding [BZ #xxxxx]

[PATCH] support: Add TEST_COMPARE_BLOB, support_quote_blob

[PATCH] Use correct includes in benchtests

[PATCH] v12 Improves __ieee754_exp() performance by 6-11% on aarch64/sparc/x86.

[PATCH] x86: Add __sigsetjmp_cancel and __setjmp_cancel

[PATCH] x86: Use pad in pthread_unwind_buf to preserve shadow stack register

[PATCH]: update leapseconds

[PATCH][BZ 22848] Update LC_TIME for Catalan

[PING2][PATCH] aarch64: Optimized memcmp for medium to large sizes

[PING][PATCH v2 0/2] Correct absolute (SHN_ABS) symbol run-time calculation [BZ #19818]

[PING][PATCH] aarch64: Optimized memcmp for medium to large sizes

[RFC PATCH] Disable uninitialized warnings around va_arg(, long double)

[RFC PATCH] Introduce pt-compat-stubs and use it to replace pt-vfork. (Architecture maintainer feedback wanted.)

Re: [RFC PATCH] Introduce pt-compat-stubs and use it to replace pt-vfork. (Architecture maintainer feedback wanted.)

Re: [RFC] DT_WHT

[RFC] Toward Shareable POSIX Signals

[RFC]: Repurpose glibc_X.Y keyword to mean "Fixed in glibc X.Y release branch"

Add narrowing subtract functions [committed]

Add SHT_X86_64_UNWIND to elf.h (bug 20079)

Are LIBC probes part of the ABI?

Are the pthread "compatibility" copies of symbols in libc still necessary?

best-fit algorithm with bitmap heap

The collation update to the new ISO file made all locales almost twice as big

Re: Fix powerpc ifunc-sel.h build for -Os

Fix s390 -Os iconv build

Fix signed integer overflow in random_r (bug 17343)

Re: glibc 2.25 seems to have broken AddressSaniitzer Inbox x glibc x sanitizer x

glibc 2.27 regression on powerpc-linux-gnuspe

GNU Cauldron 2018 - GNU C Library BoF

Re: libc-alpha Digest 2 Mar 2018 10:59:55 -0000 Issue 6215

Moving the Japanese Era data out of the locales

New Brazilian Portuguese PO file for 'libc' (version 2.26.9000)

New Croatian PO file for 'libc' (version 2.26.9000)

New version of the libidn2 patch

Per call-site malloc specialization.

Ping Re: Add SHT_X86_64_UNWIND to elf.h (bug 20079)

PING: [PATCH] Remove hidden __libc_longjmp

PING: [PATCH] x86: Add __sigsetjmp_cancel and __setjmp_cancel

Possible inline malloc alternatives: bitmap

Re: Question: more languages to support alternative month names?

Questions about failing testcase nptl/test-mutex-printers

Recent libm changes broke m68k

Remote sync filesystem to handle distribution space usage

Remove more old-compilers parts of sysdeps/x86/fpu/bits/mathinline.h [committed]

Remove old-GCC parts of x86 bits/mathinline.h [committed]

Remove powerpc, sparc fdim inlines (bug 22987) [committed]

Remove sysdeps/x86/fpu/bits/mathinline.h __finite inline [committed]

Remove unused frame.h header, sigcontextinfo.h macros

Removing bits/mathinline.h

RFA: Need to extend x86 psABI to support thread cancellation and alternate signal stack

RFC V3 [1/2] test-in-container

RFC: Proposal for implementing libmvec on aarch64

Re: RFC: remove the "tile" architecture from glibc

SIGBUS failure for misc/tst-bz21269 on i386

state of the install-bootstrap-headers patch

Unify umount function implementations (bug 16552)

Update i386 libm-test-ulps [committed]

Re: Upstreaming the glibc Hurd port

Use x86_64 backtrace as generic version

Y2038 Proofness roadmap


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc