This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 4/9] Use SCANF_LDBL_IS_DBL instead of __ldbl_is_dbl.


On Wed, 07 Mar 2018, Zack Weinberg wrote:

>Change the callers of __vfscanf_internal and __vfwscanf_internal that
>want to treat 'long double' as another name for 'double' (all of which
>happen to be in sysdeps/ieee754/ldbl-opt/nldbl-compat.c) to communicate
>this via the new flags argument, instead of the per-thread variable
>__no_long_double and its __ldbl_is_dbl wrapper macro.

The patch looks good to me

>	(__nldbl___isoc99_vfscanf, __nldbl___isoc99_sscanf)
>	(__nldbl___isoc99_vsscanf, __nldbl___isoc99_vscanf)
>	(__nldbl___isoc99_fscanf, __nldbl___isoc99_scanf)
>	(__nldbl___isoc99_vfwscanf, __nldbl___isoc99_swscanf)
>	(__nldbl___isoc99_vswscanf, __nldbl___isoc99_vwscanf)
>	(__nldbl___isoc99_fwscanf, __nldbl___isoc99_wscanf):
>	Call __vfscanf_internal / __vfwscanf_internal directly, passing
>	SCANF_LDBL_IS_DBL | SCANF_ISOC99_A.  Set up a strfile if necessary.
>        Do not set __no_long_double.  Normalize variable names.
 ~~~~~~~~
Spaces that could be converted to tabs.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]