libc-alpha archive
subject index for May, 2014

This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

*PING* Re: Updated rwlock-in-C and rwlock-elision patchkit

Re: [1/3] elf/dl-lookup.c: Move STB_GNU_UNIQUE handling to a function

[BZ #14501] Add nhn_MX locale

[BZ #16905] New collation for hanzi

[COMMITTED 1/3] alpha: Define ELF_MACHINE_NO_RELA

[COMMITTED 1/4] alpha: Remove nptl/fork.c

[COMMITTED 2/3] alpha: Remove bits/siginfo.h (BZ 16966)

[COMMITTED 2/4] alpha: Merge standard and nptl clone.S

[COMMITTED 3/3] alpha: fix sa_flags type (BZ 16967)

[COMMITTED 3/4] alpha: Consolidate NPTL/non versions of vfork

[COMMITTED 4/4] alpha: Move remaining files out of sysdeps/unix/sysv/linux/alpha/nptl/

[COMMITTED PATCH] Add stub arch-fork.h header.

[COMMITTED PATCH] Consolidate not-cancel.h files.

[COMMITTED PATCH] Deconditionalize use of LLL_LOCK_INITIALIZER in bits/libc-lock.h.

[COMMITTED PATCH] Fix -Wundef for _UTSNAME_DOMAIN_LENGTH.

[COMMITTED PATCH] Fix -Wundef issues in generated errlist.c.

[COMMITTED PATCH] Fix -Wundef warnings for _IO_JUMPS_OFFSET.

[COMMITTED PATCH] Fix powerpc fork after i386 reorganization.

[COMMITTED PATCH] Fix some termios.h conformtest failures on sparc.

[COMMITTED PATCH] i386: Remove useless pthread_spin_{init,unlock} wrapper files.

[COMMITTED PATCH] IA64: Convert fork.c to arch-fork.h

[COMMITTED PATCH] Move remaining files out of nptl/sysdeps/unix/sysv/linux/x86/.

[COMMITTED PATCH] Move remaining nptl/sysdeps/unix/sysv/linux/i386/ files.

[COMMITTED PATCH] Move remaining nptl/sysdeps/unix/sysv/linux/x86_64/ files.

[COMMITTED PATCH] Move rules for Linux-specific pldd program to Linux-specific Makefile.

[COMMITTED PATCH] Move x86_64 timer_*.c out of nptl/

[COMMITTED PATCH] Silence a missing-noreturn warning for _Unwind_Resume.

[COMMITTED PATCH] Some configure-related decrufting.

[COMMITTED PATCH] x86: Consolidate NPTL fork.

[COMMITTED PATCH] x86: Consolidate NPTL/non versions of clone

[COMMITTED PATCH] x86: Move abilist files out of nptl/ subdirectories.

[COMMITTED PATCH] x86_64: Remove useless pthread_spin_{init,unlock} wrapper files.

[COMMITTED] alpha: Create __syscall_nocancel entry points

[COMMITTED] alpha: Do non-default symbols in pt-vfork.S

[COMMITTED] malloc/malloc.c : Remove nested function mi_arena.

[COMMITTED] PowerPC: Fix copysignf optimization macro

[COMMITTED] PowerPC: Fix memchr ifunc hidden symbol for PPC32

[COMMITTED] PowerPC: Fix multiarch hypotf PPC64 path

[COMMITTED] PowerPC: Remove 64 bits instructions in PPC32 code

[COMMITTED] PowerPC: Remove unneeded copysign[f] macros

[COMMITTED] Revert removal of XDR currency from locale/iso-4217.def

[glibc PATCH v4 resend] fcntl-linux.h: add new definitions and manual updates for open file description locks

[manjian2006 at gmail dot com: Propose to Use madvise API on Runtime Loader]

[PATCH 0/2] Fix pthread_spin_lock for sparc32 and 64

[PATCH 0/2] inprove vfork compat

[PATCH 0/6] aarch64: syscall cleanups

[PATCH 0/6] Use common <bits/mman-linux.h> for various ports

Re: [PATCH 1.1] Clean up netgroupcache

[PATCH 1/2 roland/nptl] ARM: Consolidate NPTL/non versions of vfork

[PATCH 1/25] Remove nested functions: crypt/md5-crypt.c

[PATCH 1/2] Aarch64: Cleanup math_private.h

Re: [PATCH 1/2] Add a fast path for C rd/wrlock

Re: [PATCH 1/2] ARM: Improve fenv implementation

[PATCH 1/2] Fixed pthread_spin_lock on sparc32/64 (bug 16882)

[PATCH 1/2] Only support ifunc in nptl/pt-vfork.c

Re: [PATCH 1/2] Single thread optimization for malloc atomics

[PATCH 1/3 roland/nptl] Consolidate NPTL vs non clone.S for ARM.

[PATCH 1/3] Add a fast path for C rd/wrlock v2

[PATCH 1/5] PowerPC: Consolidate NPTL/non versions of vfork

[PATCH 1/6] aarch64: Merge rtld_errno offset with memory reference

[PATCH 1/6] Use bits/mman-linux.h for AM33

Re: [PATCH 2/2 roland/nptl] x86: Consolidate NPTL/non versions of vfork

[PATCH 2/2] Aarch64: Cleanup math_private.h

Re: [PATCH 2/2] ARM: Improve fenv implementation

Re: [PATCH 2/2] Initialize all of datahead structure in nscd [BZ #16791]

[PATCH 2/2] New test for pthread_spin_lock (bug 16882)

[PATCH 2/2] Only provide non-default symbols in libpthread for vfork

Re: [PATCH 2/2] PowerPC: libc single-thread lock optimization

[PATCH 2/3 roland/nptl] Consolidate NPTL configury for ARM/Linux.

[PATCH 2/3] Remove x86 assembler rwlock code

[PATCH 2/5] PowerPC: Consolidate NPTL/non versions of clone

[PATCH 2/6] aarch64: Merge __local_multiple_threads offset with memory reference

[PATCH 2/6] Use bits/mman-linux.h for ARM

[PATCH 3/3 roland/nptl] Verbatim NPTL file moves for ARM/Linux.

[PATCH 3/3] Add adaptive elision to rwlocks v2

[PATCH 3/5] PowerPC: Move powerpc64 timer_*.c out of nptl/

[PATCH 3/6] aarch64: Tidy syscall error check

[PATCH 3/6] Use bits/mman-linux.h for IA64

[PATCH 4/5] PowerPC: Move NPTL public ABI headers to, sysdeps/powerpc/nptl/.

[PATCH 4/6] aarch64: Improve sysdep-cancel.h

[PATCH 4/6] Use bits/mman-linux.h for M68K

[PATCH 5/5] PowerPC: Move remaining, nptl/sysdeps/unix/sysv/linux/powerpc/ files.

[PATCH 5/6] aarch64: Use tpidr_el0 rather than __read_tp in librt

[PATCH 5/6] Use bits/mman-linux.h for MIPS

[PATCH 6/6] aarch64: Use tpidr_el0 rather than __errno_location in librt

[PATCH 6/6] Use bits/mman-linux.h for TILE

Re: [PATCH RFC] Imporve 64bit memcpy performance for Haswell CPU with AVX instruction

Re: [PATCH RFC] Imporve 64bit memset performance for Haswell CPU with AVX2 instruction

[PATCH roland/aarch64] AArch64: Convert fork.c to arch-fork.h

[PATCH roland/alpha] Alpha: Convert fork.c to arch-fork.h

[PATCH roland/arm-strcmp] Make armv7 strcmp assembly compatible with ARM mode and SFI.

[PATCH roland/arm-unwind-header] Move ARM internal unwind.h header to the right sysdeps directory.

[PATCH roland/exit-thread] Clean up __exit_thread.

[PATCH roland/getpid] Simplify getpid handling of the race case.

[PATCH roland/nptl-arm] ARM: Convert fork.c to arch-fork.h

[PATCH roland/nptl-hppa] HPPA: Consolidate NPTL/non versions of clone

[PATCH roland/nptl-hppa] HPPA: Convert fork.c to arch-fork.h

[PATCH roland/nptl-ia64] IA64: Consolidate NPTL/non versions of clone

[PATCH roland/nptl-ia64] IA64: Convert fork.c to arch-fork.h

[PATCH roland/nptl-m68k] m68k: Convert fork.c to arch-fork.h

[PATCH roland/nptl-microblaze] MicroBlaze: Convert fork.c to arch-fork.h

[PATCH roland/nptl-s390] S390: Convert fork.c to arch-fork.h

[PATCH roland/nptl-sh] SH: Consolidate NPTL/non versions of clone

[PATCH roland/nptl-sh] SH: Consolidate NPTL/non versions of vfork

[PATCH roland/nptl-sh] SH: Convert fork.c to arch-fork.h

[PATCH roland/nptl-sparc] SPARC: Convert fork.c to arch-fork.h

[PATCH roland/nptl-tile] Tile*: Convert fork.c to arch-fork.h

[PATCH roland/nptl] Move NPTL public ABI headers for ARM to sysdeps/arm/nptl/.

[PATCH roland/nptl] Move NPTL public ABI headers for x86 to sysdeps/x86/nptl/.

[PATCH roland/waitpid] Fix __waitpid_nocancel link error

[PATCH v1.1] benchtests: Add new directive for benchmark initialization hook

Re: [PATCH v1.1] Remove duplicate code in elf/dl-deps.c

Re: [PATCH v1.2] Deprecate malloc_(sg)et state.

[PATCH v1.2] Remove duplicate code in elf/dl-deps.c

[PATCH v2 0/2] improve vfork compat

[PATCH v2 0/9] aarch64 syscall cleanups

[PATCH v2 1/2] Only support ifunc in nptl/pt-vfork.c

Re: [PATCH v2 1/4] Nios II port submission, elf subdir

[PATCH v2 1/9] aarch64: Remove DOARGS/UNDOARGS macros

[PATCH v2 2/2] Only provide non-default symbols in libpthread for vfork

[PATCH v2 2/9] aarch64: Tidy syscall error check

[PATCH v2 3/9] arm,aarch64: Remove SINGLE_THREAD_P_PIC

[PATCH v2 4/9] aarch64: Improve sysdep-cancel.h

[PATCH v2 5/9] aarch64: Use tpidr_el0 rather than __read_tp in librt

[PATCH v2 6/9] aarch64: Use tpidr_el0 rather than __errno_location in librt

[PATCH v2 7/9] aarch64: Rely on syscalls preserving registers

[PATCH v2 8/9] aarch64: Consolidate NPTL/non versions of clone

[PATCH v2 9/9] aarch64: Consolidate NPTL/non versions of vfork

Re: [PATCH v2] ARM: Add optimized ARMv7 strcmp implementation

Re: [PATCH v2] benchtests: Add malloc microbenchmark

[PATCH v2] Clean up check_pf allocation pattern. addresses

[PATCH v2] fix nl_langinfo with static linking (BZ #16915)

[PATCH v2] Handle possible vararg promotion of mode_t in open and friends

[PATCH v2] ptsname_r: don't leak uninitialized memory

Re: [PATCH v2][BZ 16852] Do not clobber recvmmsg argument.

[PATCH v3 0/9] aarch64 syscall cleanups

[PATCH v3 1/9] aarch64: Tabify sysdep-cancel.h

[PATCH v3 2/9] aarch64: Share code in syscall-cancel.h

[PATCH v3 3/9] aarch64: Pass regno parameter to SINGLE_THREAD_P

[PATCH v3 4/9] aarch64: Improve syscall-cancel stack frame

[PATCH v3 5/9] aarch64: Use tpidr_el0 rather than __read_tp in librt

[PATCH v3 6/9] aarch64: Use tpidr_el0 rather than __errno_location in librt

[PATCH v3 7/9] aarch64: Rely on syscalls preserving registers

[PATCH v3 8/9] aarch64: Consolidate NPTL/non versions of clone

[PATCH v3 9/9] aarch64: Consolidate NPTL/non versions of vfork

[PATCH v3.5 0/2] aarch64 syscall cleanups

[PATCH v3.5 1/2] aarch64: Fix error return from __ioctl

[PATCH v3.5 2/2] aarch64: Remove PSEUDO_RET

[PATCH v3] ptsname_r: don't leak uninitialized memory (BZ #16917)

[PATCH v4] ptsname_r: don't leak uninitialized memory (BZ #16917)

[PATCH, MIPS] Fix *_SUB instruction macros

[PATCH] Aarch64 - Rewrite feupdateenv

[PATCH] Aarch64 : Remove ISB after FPCR write

[PATCH] AArch64: Fix handling of nocancel syscall failures

[PATCH] AARCH64: remove asm/prtace.h inclusion in sys/user.h and sys/procfs.h

FW: [PATCH] Add generic HAVE_RM_CTX implementation

[PATCH] Add mmapped count and size in malloc_info

[PATCH] ARM - Rewrite feupdateenv

[PATCH] ARM: Allow auto-detection of linker relro feature

[PATCH] ARM: Avoid unnecessary FPSCR writes

[PATCH] ARM: Fix handling of concurrent TLS descriptor resolution

[PATCH] ARM: Use libc calls for fenv functions

[PATCH] benchtests: Add new directive for benchmark initialization hook

[PATCH] Converted benchmark to benchtest.

Re: [PATCH] Correct mutex type check for disable lock elision via pthread_mutexattr_settype call

[PATCH] Correctly handle %p in wprintf

[PATCH] Don't use catomic functions in mcount

Re: [PATCH] Fix -Wundef for FEATURE_INDEX_1.

Re: [Patch] Fix __mips16 undef macro warnings.

Re: [PATCH] Fix ARM NAN fraction bits

[PATCH] Fix excessive ULP for y1_upward (0x2p+0) in test-float and test-ifloat.

[PATCH] Fix invalid file descriptor reuse while sending DNS query

[PATCH] Fix macro warning on HAVE_PT_CHOWN

[PATCH] fix nl_langinfo with static linking

Re: [Patch] Fix ONE_DIRECTION undef warnings.

[PATCH] Fix parsing of getai result from nscd

Re: [PATCH] Fix prototype for eventfd

[PATCH] Fix race between sem_post and semaphore destruction [BZ #12674]

[Patch] Fix remaining ONE_DIRECTION warning messages

[PATCH] Fix searching localedef input on I18NPATH (BZ #16984)

[PATCH] fix static TLS consumption by TLS descriptors

[PATCH] Fix strtold on 32-bit sparc (and probably others) (BZ #16965)

[PATCH] Fix tst-tls9-static build

[PATCH] Fix typo in assertion

[PATCH] Fix unbound stack use in NIS NSS module

Re: [PATCH] Fix v9/64-bit strcmp when string ends in multiple zero bytes.

Re: [PATCH] Inline useless nested function mi_arena.

Re: [PATCH] linux, x86: Add 32 bit vDSO time function support

[PATCH] locale.5: document glibc conventions regarding days and week

Re: [PATCH] malloc: Add mallopt test.

[PATCH] manual: Update LOCPATH documentation

[PATCH] manual: Update prototypes for alphasort and friends

Re: [PATCH] math: skip test-fenv-preserve.c if no FE_INVALID.

[PATCH] Optimization for strncpy and stpncpy on Power7

Re: [PATCH] Power7 optimizations for strncpy and stpncpy.

[PATCH] PowerPC: clean BSD Terminal Modes expectation in termios.h

[PATCH] ptsname_r: don't leak unitialized memory

Re: [PATCH] Re: tzselect: use zonedir instead of current working directory

Re: [PATCH] Remove arm lowlevellock.c

Re: [PATCH] Remove divide from _ELF_DYNAMIC_DO_RELOC

[PATCH] Remove duplicate code in elf/dl-deps.c

[PATCH] Remove last use of USE___THREAD

Re: [PATCH] Remove PRI_MACROS_BROKEN define usage

[PATCH] Remove second argument from TLS_INIT_TP macro

[PATCH] Replace __int128 with __int128_t in sysdeps/x86_64/link-defines.sym

Re: [PATCH] Return EAI_AGAIN for AF_UNSPEC when herrno is TRY_AGAIN (BZ #16849)

Re: [PATCH] S/390: Port of lock elision to System/z

[PATCH] SPARC: add EFD_SEMAPHORE in <bits/eventfd.h>

[PATCH] SPARC: add prlimit and prlimit64 in <bits/resource.h> (BZ #16943)

Re: [PATCH] stdlib/gmp-impl.h: Silence -Wundef warning for USE_STACK_ALLOC

[PATCH] sys/time.h: Remove comment about timercmp and add test

[PATCH] tzselect: use zonedir instead of current working directory

Re: [PATCH] Use mode_t in open and friends

Re: [PATCH] Use statfs64() in shm_open() and posix_getpt().

[PATCH] Valid bench.out against a JSON schema

Re: [PATCH], RFC, add support for __float128/__ibm128 types on PowerPC

Re: [PATCH], RFC, add support for __float128/__ibm128 types on PowerPC

[PATCH][AARCH64] correct alignment of TLS_TCB_ALIGN

Re: [PATCH][BZ #16876] Fix typo in nptl/sockperf.c

Re: [PATCH][BZ #16877] Fix typo in nscd/selinux.c

Re: [PATCH][BZ #16907] Do not disable __attribute__ when you include argp.h

[PATCH][BZ #16907] Do not disable __attribute__ when you include argp.h

[PATCH][BZ #16907] Sync argp.h __attribute__ with gnulib.

Re: [PATCH][BZ #6803] Set errno for scalbln, scalbn

[PATCH][SPARC] missing membar in niagara2_memcpy

[PATCHv2, MIPS] Add support for O32 FPXX and program header based ABI information

[PING] Re: DNSSEC support in stub-resolver

[PING][PATCH v1.1] benchtests: Add new directive for benchmark initialization hook

[PING][PATCH v2][BZ 16852] Fix recvmmsg prototype

[PING][PATCH] Inline useless nested function mi_arena.

[PING][PATCH] Use NSS_STATUS_TRYAGAIN to indicate insufficient buffer (BZ #16878)

[PING][PATCH] Valid bench.out against a JSON schema

[PING][PATCH][BZ #16876] Fix typo in nptl/sockperf.c

[PING][PATCH][BZ #16877] Fix typo in nscd/selinux.c

[PING][PATCH][BZ #6803] Set errno for scalbln

Re: [PING^2] RFC [PATCH] BZ#1077902: New API gettimezone

[PING^2][PATCH] Use NSS_STATUS_TRYAGAIN to indicate insufficient buffer (BZ #16878)

Re: [PING^3] RFC [PATCH] BZ#1077902: New API gettimezone

[PING^4][PATCH 3/2] Use strspn/strcspn/strpbrk ifunc in internal calls.

[PING^5][PATCH 3/2] Use strspn/strcspn/strpbrk ifunc in internal calls.

[PING^6][PATCH v1.1] Fix offset computation for append+ mode on switching from read (BZ #16724)

[PING^7][PATCH v1.1] Fix offset computation for append+ mode on switching from read (BZ #16724)

[PING^8][PATCH v1.1] Fix offset computation for append+ mode on switching from read (BZ #16724)

Re: [RESEND][BZ #15132][PATCH] avoid stat/fstat in statvfs/fstatvfs

[RFC, PATCH, MIPS] Add support for O32 FPXX and program header based ABI information

Re: [RFC] killing remaining USE___THREAD use

[RFC][PATCH v2] Add reallocarray function.

[RFC][PATCH] Add reallocarray function.

Re: [v4, resend] fcntl-linux.h: add new definitions and manual updates for open file description locks

[WIP] Fix HAVE_CONFIG_H -Wundef warnings.

Re: Actually setting up patchwork on sourceware

addition of az_IR or azb_IR locale

Re: alloca vs malloc

Clean up ARM old-ABI symbol versioning relics

Re: Clean up kernel version conditionals for pre-2.6.32 kernels

conformtest: clean up POSIX expectations for sys/mman.h, sys/stat.h, sys/types.h

conformtest: clean up POSIX expectations for termios.h, time.h

conformtest: clean up POSIX expections for sys/utsname.h, sys/wait.h

Consistently use $(elf-objpfx)

Re: Correct minimal test suite changes for elision enabled kernels.

Create linaro/ namespace in git repository

Define TSVTX in tar.h for older POSIX (bug 16978)

Re: DNSSEC support in stub-resolver

Don't mention linuxthreads in Depend files

Don't require test wrappers to preserve environment variables

Fix acosh (1) in round-downward mode (bug 16927)

Fix ARM build with GCC trunk

Fix cacos (+Inf + finite*i) in round-downward mode (bug 16928)

Fix erf underflow handling near 0 (bug 16516)

Fix log10 (1) in round-downward mode (bug 16977)

Fix log1pl (LDBL_MAX) in FE_UPWARD mode (bug 16564)

glibc manual: html character entity incorrect

GNU Tools Cauldron 2014 - Special hotel rates will expire soon

GNU Tools Cauldron 2014 - Update

The Great -Wundef purge - Read this if you have a -Wundef-fix patch!

guidelines for code reuse vs. one-function-per-file?

Ignore my previous old emails...

Include SSE state in i386 fenv_t (bug 16064)

Re: Locale eo ready to be added - next step?

make nptl no longer an add-on?

Re: malloc/obstack: Merge obstack code back from gnulib

MIPS header file question

Re: New Esperanto PO file for 'libc' (version 2.18.90.20140105)

New Swedish PO file for 'libc' (version 2.18.90.20140105)

nl_langinfo question

Fwd: non-ifunc pt-vfork

nptl refactoring; nacl port

Patch review workflow [was: patchwork.sourceware.org is live!]

patchwork.sourceware.org is live!

ping Re: [PATCH] Fix excessive ULP for y1_upward (0x2p+0) in test-float and test-ifloat.

Ping Re: Clean up kernel version conditionals for pre-2.6.32 kernels

Ping Re: conformtest: clean up POSIX expectations for sys/mman.h, sys/stat.h, sys/types.h

Ping Re: conformtest: clean up POSIX expectations for termios.h, time.h

Ping Re: conformtest: clean up POSIX expections for sys/utsname.h, sys/wait.h

Ping Re: Fix erf underflow handling near 0 (bug 16516)

Ping Re: Remove __ASSUME_ATFCTS conditionals in sysdeps/unix/sysv/linux/

Ping^2 Re: Clean up kernel version conditionals for pre-2.6.32 kernels

Ping^2 Re: conformtest: clean up POSIX expectations for sys/mman.h, sys/stat.h, sys/types.h

Ping^2 Re: conformtest: clean up POSIX expections for sys/utsname.h, sys/wait.h

Ping^2 Re: Remove __ASSUME_ATFCTS conditionals in sysdeps/unix/sysv/linux/

Re: PowerPC: libc single-thread lock optimization

Re: problem about pthread_mutexattr_gettype

Re: proposal: Thread Properties API

Propose to Use madvise API on Runtime Loader

Re: pthread_rwlock and writers preference

Reduce kernel-features.h duplication

Remove __ASSUME_ATFCTS conditionals in sysdeps/unix/sysv/linux/

Re: Remove second argument from TLS_INIT_TP macro

Requesting CVEs for glibc security issues

Re: strtod rounding wrt. long double

Updated "Contribution Checklist" to reflect ports/ deprecated status.

Updated rwlock-in-C and rwlock-elision patchkit

Re: Updated rwlock-in-C patchkit

Use existing makefile variables for dependencies on glibc libraries

why does rwlock prefer readers by default?

why Glibc does not build with clang?

Re: why Glibc does use alloca?

zonefile changes and long running processes.


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc