This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Use default_attr to store default pthread attributes


> 	* allocatestack.c (allocate_stack): Use DEFAULT_ATTR.

The caps convention is only for local variables.

> -/* Default stack size.  */
> -extern size_t __default_stacksize attribute_hidden;
> +/* Default pthread attributes.  */
> +extern struct pthread_attr default_attr;
> +hidden_proto (default_attr);

It's far simpler just to make this an __ name with attribute_hidden.
The hidden_proto sort of thing is really only for public names.
(Incidentally, no trailing ; after hidden_proto.)

This makes the various renamings of local-scope variables called
default_attr unnecessary, though that's not a bad idea just for
readability/grepability anyway.  But really that is then a cosmetic change
that should be separate from all this.


Thanks,
Roland


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]