This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Problems with message catalogues on Red Hat Linux 7 on Alpha


I'm new to Linux, and to this list.

I tried to get the faq for this list from but there isn't one available. So
forgive me if this is the wrong place to ask this sort of question. 

I'm porting some software from Tru64 UNIX on Alpha to Red Hat Linux v7.0 on
Alpha. The software uses message catalogues for internationaling error
messages. I am having problems with the message catalogue utilities and
functions on Linux.

My first problem was that I cannot find a mkcatdefs command on Linux. So as
a work-around I ran mkcatdefs on Tru64 UNIX, and copied the generated file
to Linux. I was then able to use the gencat command on Linux. This
workaround is acceptable

But when I run a program which calls catopen() & catgets() to get a message
from the catalogue, I am getting odd results.  For some messages it works
fine; for others I get back a string of blank spaces of the wrong size. 

Am I missing something here or are message catalogues broken on Linux ?

Also, does the "alpha" in "libc-alpha" mean the C library for Linux on Alpha
systems? I suspect not, as I did not see libc lists for other architectures.
So what does "alpha" stand for?

Thanks & regards,

John Wood, Software Engineer, Partner Portfolio Engineering,
Compaq Computer Ltd, Imperial Way, Reading, Berkshire, RG2 0TE, England

Tel. (+44)(0)118-920-4124       Fax. (+44)(0)118-9204146

E-mail:     Web:

Compaq Internal: Exchange GAL: Wood, John (REO); Location: REO-2 FM8

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]