This is the mail archive of the libc-alpha@cygnus.com mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: new linux chown


At 10:46 10.06.98 , Andreas Schwab wrote:
>Matt McLean <keys@brio.yikes.com> writes:
>
>|> looking at uli's sysdeps/unix/sysv/linux/i386/chown.c,
>|> 
>|> it seems to me that it shouldn't be an architecture dependant file. from
>|> what i can tell, right now the alpha, i386, mips, and ppc kernels are all 
>|> aware of the new chown (and the old one being renamed lchown).
>
>Neither the alpha nor the m68k have renamed chown.  Only i386, mips and
>ppc are following this brain damage.

This whole mess drives me crazy. What is the best solution for that?
Currently the situation as I understand it, is as follows:

Intel:
              name         functionality     syscallnumber
old kernels   chown        lchown            16
new kernels   lchown       lchown            16  (calling sys_lchown)
              chown        chown             182 (calling sys_chown)

Alpha:
              name         functionality     syscallnumber
old kernels   chown        lchown            16
new kernels   chown        chown             16  (calling sys_chown)
              lchown       lchown            208 (calling sys_lchown)

I thought renaming is necessary to be compatible? On alpha kernel you
suddenly get new functionality for the same syscall# between different
kernel versions, thus confusing older (binary) libc's (happened to me/PPC
people), breaking older binary applications (noteably fileutils-3.16). The
functionality change (calling sys_lchown) was absolutely necessary for PPC.
On the naming change we simply followed the mainstream (Intel), otherwise
probably a scheme like that would be necessary in the kernel:

              name         functionality     syscallnumber
newer kernel  old_chown    lchown            16  (calling sys_lchown)
              chown        chown             182 (calling sys_chown)
              lchown       lchown            ??? (calling sys_lchown)


I'm willing to use/implement any solution on PPC, as long as it is a
commonly agreed one. 

Franz.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]