This is the mail archive of the mailing list for the Insight project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Problem with source paths with new Cygwin release

To sum up a bit:

I rebuilt the original snapshot from August 8 2003 with updated
cygwin environment, and the problem with missing source paths

I then fetched an Insight snapshot from September 5 and built
it with updated cygwin environment, and got the same error
as already reported by Craig:

gdbtk/generic/gdbtk-cmds.c:2891: warning: implicit declaration of function
make[1]: *** [gdbtk-cmds.o] Error 1

OK, so there has been something changed with conversion to full paths,
it looks like some API change somewhere in Cygwin if you ask me....

I don't have any solution for this right now except going back
to older version of at least the following modules:

cygutils: 1.2.1-2 -> 1.1.4-2
cygwin: 1.5.3-1 -> 1.3.22-1

Then Insight works with respect to source paths, but the bash
shell doesn't even start. If I go back on bash:

bash: 2.05b-13 -> 2.05b-9

I can start the bash shell, but I get lots of errors. Probably
in a quite useless state...

And that is how far I am right now...



Today after updating the Cygwin environment, Insight started
having problems with source paths when doing high level debugging.
Most source files are shown only in assembly code, and when
using the Insight function browser, the source paths seem to have
been stripped away from almost all source files. Thus, only
assembly code is shown.

The new Cygwin package was 1.5.3-1. I used the Cygwin setup tool
and went back to 1.3.22-1, and everything worked fine again.

I have been working with Insight in Windows environment
using Cygwin. I built Insight based on a snapshot from August
8 2003 probably using Cygwin 1.3.22-1 release. It was built
for PowerPC/ELF architecture.

Anyone happen to know the reason?

Is it likely that rebuilding Insight after an upgrade would also
solve the problem?

Best regards
Kristian Otnes

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]