This is the mail archive of the insight@sources.redhat.com mailing list for the Insight project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: [RFA] 100494 fix


Nice work Larry.

But please rename run_method to rm_method (like rm_frame).
This way we do not confuse the state variables that indicate weather
we want to run or continue (run_run and run_cont) and the variables
that contain window paths.


Another thing: Your patch seem to have a mix of "diff" and "cvs diff".
"patch" didn't like it.  I had to hand edit it several times in order
to try it.

cvs diff is the preferable method.  Unless the contributor does not have
a cvs tree, the patch should be created by a cvs diff.

Thanks for the patch.

Regards,
Fernando



Larry Smith wrote:
> 
> 2000-10-31  Larry Smith  <lsmith@redhat.com>
> 
>         * change targetselection.it*, put Run Program and Continue
> From...
>         buttons into a frame and disables both of them when the target
> is
>         "exec".
> 
> RCS file: /cvs/src/src/gdb/gdbtk/library/targetselection.ith,v
> retrieving revision 1.2
> diff -r1.2 targetselection.ith
> 57a58,59
> >
> >     variable run_method
> >
> 
> > cvs diff -r 1.5 targetselection.itb
> Index: targetselection.itb
> ===================================================================
> RCS file: /cvs/src/src/gdb/gdbtk/library/targetselection.itb,v
> retrieving revision 1.5
> diff -r1.5 targetselection.itb
> 489a490,493
> >   set rm_frame [iwidgets::labeledframe $frame.run_method -labelpos nw -labeltext "Run Method" ]
> >   set run_method [ $rm_frame childsite ]
> >
> >   set rm_label [label $frame.label -text "Run Method:"]
> 491c495
> <   radiobutton $frame.cont -text {Continue from Last Stop} -value 1
> -variable $var \
> ---
> >   radiobutton $run_method.cont -text {Continue from Last Stop} -value 1 -variable $var \
> 495c499
> <   radiobutton $frame.run -text {Run Program} -value 1 -variable $var \
> ---
> >   radiobutton $run_method.run -text {Run Program} -value 1 -variable $var \
> 501,504c505,516
> <   grid $frame.attach $frame.run -sticky w
> <   grid $frame.load   $frame.cont -sticky w
> <   grid $frame.afterl -sticky we -columnspan 2
> <   grid $frame.aftere -sticky we -columnspan 2
> ---
> >
> >   grid $frame.label -column 1 -row 0 -sticky w
> >   grid $frame.attach -column 0 -row 1 -ipady 2
> >   grid $frame.load -column 0 -row 2 -ipady 2
> >
> >   grid $run_method.run -column 0 -row 1 -sticky w -ipady 2
> >   grid $run_method.cont -column 0 -row 2 -sticky w -ipady 2
> >
> >   grid $rm_frame -column 1 -row 1 -rowspan 2 -sticky nsew -ipady 2
> >
> >   grid $frame.afterl -row 4 -sticky we -columnspan 2 -ipady 2
> >   grid $frame.aftere -sticky we -columnspan 2 -ipady 2
> 724a737,745
> >
> >   if { "$target" == "exec" } {
> >     $run_method.run configure -state disabled -value 1
> >     $run_method.cont configure -state disabled
> >   } else {
> >     $run_method.run configure -state normal
> >     $run_method.cont configure -state normal
> >   }
> 
> --
>  .-.    .-. .---. .---. .-..-. | "Bill Gates is just a monocle
>  | |__ / | \| |-< | |-<  >  /  | and a Persian Cat away from
>  `----'`-^-'`-'`-'`-'`-' `-'   | being one of the bad guys in a
>        My opinions only.       | James Bond movie." -- D Miller

-- 
Fernando Nasser
Red Hat - Toronto                       E-Mail:  fnasser@redhat.com
2323 Yonge Street, Suite #300
Toronto, Ontario   M4P 2C9

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]